May 11, 2021, 12:02:11 am
Welcome, Guest. Please login or register.
Did you miss your activation email
News:

Arturia Forums



Author Topic: Keylab encoder values not updated from Ableton Live  (Read 195 times)

rolfhsp

  • Newbie
  • *
  • Posts: 1
  • Karma: 0
Keylab encoder values not updated from Ableton Live
« on: August 10, 2020, 12:46:48 am »
Hi

My setup: Ableton Live 10, Arturia Keylab 61 mkii, Akai APC40 mkii.

In Ableton I have an instrument rack with 8 macros mapped to CC16-23 (and again mapped to certain controls in Hybrid 3 plugin - not important)
Keylab is in User mode, and set up to use CC16-23 for the 8 first endless encoders.
APC40 also uses CC16-23 for its 8 device control endless encoders.

Now, if I change a macro value in Live directly, the two controllers behave differently when rotating the encoders corresponding to that macro.

The APC40 has no problem picking up the value set in Live (directly or from the Keylab), and updating up/down from this value.
The Keylab however resets the value to whatever value it sent the last time, and updates up/down from that value.
This is a big problem, as such a sudden change in value is very audible for certain parameters.

I have Track and Remote set to On for both input and output for both controllers in Ableton Live preferences.
Doesn't seem like the Remote setting does anything for Keylab as it correctly does for the APC40.

Is this a firmware problem/limitation in the Keylab? Hopefully not a hardware limitation...
Or is it perhaps something with my setup?

I tried experimenting a little with the Relative options in Midi Control Center, but I hit a dead end there, and besides I don't think that is the correct solution anyway.

I hope that someone could shed som light on this issue.



Regards,
Rolf
« Last Edit: August 10, 2020, 01:02:55 am by rolfhsp »

 

Carbonate design by Bloc
SMF 2.0.17 | SMF © 2019, Simple Machines