May 11, 2021, 12:13:25 pm
Welcome, Guest. Please login or register.
Did you miss your activation email
News:

Arturia Forums



Author Topic: Dealing with latency  (Read 2768 times)

Andrew Henderson

  • Full Member
  • ***
  • Posts: 191
  • Karma: 0
Dealing with latency
« on: July 19, 2020, 07:52:02 pm »
I am using my KSP in a hybrid setup, controlling external hardware synths, as well as soft synths, in Cubase 10.5.  I am unfortunately finding latency when dealing with the KSP sequencers, as they never stay 100% in time to the rest of my project.  Over time, they seem to drift and get a little worse and adding more to my project, only exaggerates this.  I would like it to stay a little more in time, to the grid.

I am using an RME Fireface 802 and like all RME devices, it runs on fantastic drivers, with VERY low latency.  I usually run at a buffer size of 128, but can go as low as 48, if need be.  The KSP is slaved to Cubase via midi clock. 

I have my hardware synths setup as external instruments in Cubase, so that they are delay compensated and these stay in time perfectly to my project, or close enough, that it can't even be noticed as a problem, if they aren't.  As of Cubase 10.5.20, midi clock is even delay compensated, greatly enhancing this functionality.  Unfortunately however, the KSP doesn't seem to be following along nicely to this.  I even created an external instrument for the KSP and routed midi clock through that from Cubase, but it doesn't really do much.  The KSP just seems to work differently, then all my other external gear, when it comes to staying tight in time.

I don't necessarily blame the KSP and am not overly surprised, but figured under even basic projects, that it would play a little tighter in time.  It makes it hard to get into things, when I can hear it is sloppy in timing.

Does anyone have any suggestions, or ideas, on how they may remedy this?  Anything would be better than nothing.  Is anyone else experiencing this, or is it just 'to be expected?'

synthcreep

  • Apprentice
  • Full Member
  • *
  • Posts: 123
  • Karma: 0
Re: Dealing with latency
« Reply #1 on: July 19, 2020, 09:58:47 pm »
Why not slave Cubase to the KSP's clock?

Also, any chance you are getting multiple clock streams messing things up?

Terrym

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1.529
  • Karma: 40
    • soundcloud.com/logicaldream
Re: Dealing with latency
« Reply #2 on: July 19, 2020, 10:41:30 pm »
Hi Andrew,
I tested the sync with cubase 10.5 a lot and found that the KSP for me was really tight and always in sync..  I guess you are on windows from reading your thread, As i use Mac only so cannot say for sure what your issue is.
But it works fine for me plus i haven't sen many reports on sync issues only the usual tempo ones.

regards

TerryM
ARTURIA Tester for Keystep pro,Audiofuse range, Microfreak,Kl49mkII,DrumBrute,Spark,Analog lab3,KLE,kl88,matrix12,Semv,Beatstep,Minibrute 2,Pigments
ASC,Vcol6, Beatstep pro, VCOL7, Synclavier v.Minibrute2s

Andrew Henderson

  • Full Member
  • ***
  • Posts: 191
  • Karma: 0
Re: Dealing with latency
« Reply #3 on: July 20, 2020, 12:48:44 am »
Thanks for the replies guys.  Yes, I am on PC.  I have thought of slaving Cubase, but I never found the DAW likes to slave well to other things.  Other weird things always seem to go on, when doing that.  No, I don't have multiple clock streams, as that is very obvious with things playing back at double time, etc.  My issues are not so severe, in fact, they are subtle, but noticeable enough that the final track will sound sloppy and unprofessional, if released that way.

So Terry, you tell me that you can have the KSP slaved to Cubase, have a fully loaded project, with lots of tracks, plugins etc and the KSP sequencers stay fully in time with the project?  No lag, or drifting?

Interesting that it is possible then!

al80

  • Jr. Member
  • **
  • Posts: 59
  • Karma: 0
Re: Dealing with latency
« Reply #4 on: July 20, 2020, 01:52:11 pm »
 maybe it is the usb connection.i have  synced  and slaved my ksp pro to cubase 9.5 for weeks now with no problems with midi din connection.maybe you have to take a look at the progect synchronization setup of cubase and the settings above the midi sync destination ports of this menu

Andrew Henderson

  • Full Member
  • ***
  • Posts: 191
  • Karma: 0
Re: Dealing with latency
« Reply #5 on: July 20, 2020, 02:39:09 pm »
maybe it is the usb connection.i have  synced  and slaved my ksp pro to cubase 9.5 for weeks now with no problems with midi din connection.maybe you have to take a look at the progect synchronization setup of cubase and the settings above the midi sync destination ports of this menu

Thanks for your help on this, but yes, this is exactly where I have already set up midi clock to be sent to the Keystep Pro.  This is also where I enabled to do so, from creating an external instrument, to help it become delay compensated.

bdrank

  • Apprentice
  • *
  • Posts: 18
  • Karma: 0
Re: Dealing with latency
« Reply #6 on: July 29, 2020, 07:40:25 am »
KSP definitely goes out of sync over time when slaved to the Cirklon, have to stop/start to get things back in sync, not sure what's causing this. Sometimes goes out of sync quick, sometimes after 64 bars, dunno.

Andrew Henderson

  • Full Member
  • ***
  • Posts: 191
  • Karma: 0
Re: Dealing with latency
« Reply #7 on: July 29, 2020, 07:22:58 pm »
KSP definitely goes out of sync over time when slaved to the Cirklon, have to stop/start to get things back in sync, not sure what's causing this. Sometimes goes out of sync quick, sometimes after 64 bars, dunno.

Thanks for confirming similar findings.  It really is disappointing and quite annoying when it happens.  For me, it certainly drifts over time on its own, but really gets worse much quicker, when I have plugins loaded onto the tracks that the sequencers are working with, in Cubase.  Having all hardware set up as external instruments in Cubase, is suppose to delay compensate such things and it always does... unless they are controlled by the KSP.  Midi clock is fully delay compensated as well now, as of the latest Cubase update, meaning it too doesn't drift or lose its place, even when plugins are loaded on tracks that are being fed midi clock.  It is only the KSP that is doing this, out of my entire setup.

razzkazz

  • Apprentice
  • *
  • Posts: 8
  • Karma: 0
Re: Dealing with latency
« Reply #8 on: September 12, 2020, 01:29:13 pm »
I have a latency issue when using Ableton Live. It can be improved by adjusting the MIDI Clock Sync delay in the preferences. This messes up the first note when a sequence/arp is first played, but after that, the output from the KSP is in sync with the DAW.

 

Carbonate design by Bloc
SMF 2.0.17 | SMF © 2019, Simple Machines