December 01, 2020, 12:01:19 am
Welcome, Guest. Please login or register.
Did you miss your activation email
News:

Arturia Forums



Author Topic: Keystep not working in any software synth  (Read 352 times)

lowwhistler

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
Keystep not working in any software synth
« on: May 02, 2020, 11:06:24 pm »
Just took delivery of a Keystep. Installed on Win 10 no problem, firmware updated no problem.
MIDI Control Center sees the device and when I press the keys, I can see MIDI events flowing.
I open Analog Lab, or any of the V Collection, and nothing. My Keylab 61 Mk2 works fine, I can see the Keystep in the Audio MIDI settings, but nothing is triggering events in the synths.
Not even tried Seq or Arp, because I cannot get a single sound from my setup.
Every other controller I plug in just works. I also tried every combination of the switches at the back too.
What on earth am I doing wrong?

gphantom

  • Sr. Member
  • ****
  • Posts: 255
  • Karma: 2
Re: Keystep not working in any software synth
« Reply #1 on: May 03, 2020, 03:15:08 am »
As far as the switches go, they should both be down for INTERNAL clock.
If that checks out, try connecting to another USB port.
If that doesn't work, try connecting the keyboard to another computer.
If that doesn't work, try a different USB Cable.
Try clicking on the keys in Analog Lab with your mouse to see if you have a sound.  If so, there's a bad connection between the Keystep and the computer.
If there's no sound by clicking on the keys with the mouse, then there's a mis-configuration with the sound out setting.

If after all that, it still doesn't work, get in contact with Arturia support.

 

Carbonate design by Bloc
SMF 2.0.17 | SMF © 2019, Simple Machines