May 16, 2021, 03:24:51 am
Welcome, Guest. Please login or register.
Did you miss your activation email
News:

Arturia Forums



Author Topic: Keylab MkII VS ABLETON LIVE 10.1.7  (Read 1015 times)

dme61079

  • Newbie
  • *
  • Posts: 1
  • Karma: 0
Keylab MkII VS ABLETON LIVE 10.1.7
« on: April 21, 2020, 10:33:41 pm »
Ok so I've bought what I thought, the best 49 key usb midi controller with aftertouch & more importantly Ableton Live integration.

So far, I've had zero joy being able to use the sliders & knobs within Ableton.

Yes, I've selected the "In" Keylab / Keylab MkII Profile within ableton & yes I've held down on the DAW button & the centre knob & selected Live & yes, I've gone into the Midi Control Center & ensured Live is selected under settings.

This keyboard is seriously locked down, unable to change parts, levels, start/stop, record... anything AAARRRGG!!!

Do I need a qualification to use this damned bit of kit or is it faulty?

Running windows 10, updated the keylab to the latest firmware throught the midi control center... oh & no multi devices selected in Ableton...does this keyboard need unlocking or something?

LBH

  • Hero Member
  • *****
  • Posts: 3.765
  • Karma: 38
Re: Keylab MkII VS ABLETON LIVE 10.1.7
« Reply #1 on: April 21, 2020, 10:52:40 pm »
Hi and welcome to Arturia forums.

It sound like you have set the controller up to use it as a keyboard. That's good.

But have you also set it up as a DAW controller like you can see here:
https://www.arturia.com/faq/keylabmkii/keylab-mkii-tips-tricks
It does'nt sound like you have done this.

Notice the note about MIDIIN2 and MIDIOUT2 in Windows.

Docgeo

  • Newbie
  • *
  • Posts: 1
  • Karma: 0
Re: Keylab MkII VS ABLETON LIVE 10.1.7
« Reply #2 on: April 28, 2020, 04:18:15 am »
I have the same issue, keylab mkii midi controller set to LIVE,  inputs set in ableton preferences properly.  Able to start stop and record, but other controls are screwy.  Moving the master slider makes a bunch of closely spaced notes in a track.  One of the white keys on keyboard toggles between session and arrangement mode, and no input to notes from keyboard.  Any other suggestions. Novation sl synched right up with ease. Thanks for time and consideration.

LBH

  • Hero Member
  • *****
  • Posts: 3.765
  • Karma: 38
Re: Keylab MkII VS ABLETON LIVE 10.1.7
« Reply #3 on: April 28, 2020, 01:54:16 pm »
Hi and welcome to Arturia forums.

Are you on Windows?
Which midi port do you use for the control surface?

It's allways a good idea to post screenshots of your preferences.

Ciggie

  • Apprentice
  • *
  • Posts: 4
  • Karma: 0
Re: Keylab MkII VS ABLETON LIVE 10.1.7
« Reply #4 on: October 01, 2020, 10:48:12 am »
Hi and welcome to Arturia forums.

It sound like you have set the controller up to use it as a keyboard. That's good.

But have you also set it up as a DAW controller like you can see here:
https://www.arturia.com/faq/keylabmkii/keylab-mkii-tips-tricks
It does'nt sound like you have done this.

Notice the note about MIDIIN2 and MIDIOUT2 in Windows.

Hello,

I have done exactly as asked for in the link provided, but I am failing to get any results. Neither in Cubase, nor in Ableton.

Heres a screenshot from Ableton, what am I doing wrong? I can get the volume faders to work at best, but the keyboard is totally unresponsive. This happened after I re-formatted my laptop and installed Windows 10 again, the keyboard was working perfectly fine a week ago, before I formatted. In the first image, Remote is only on, the faders work, and there is no screeching sound.

In the second image, if I turn Track on, there is a screeching sound coming when I move the faders.

In both cases, the keys do nothing when pressed...

The transport controls work, such as arm the track, record, stop/play etc.


LBH

  • Hero Member
  • *****
  • Posts: 3.765
  • Karma: 38
Re: Keylab MkII VS ABLETON LIVE 10.1.7
« Reply #5 on: October 01, 2020, 07:43:33 pm »
Hi and welcome to Arturia forums.

I don't use Ableton Live. You can try to check both Track and Remote in the MIDI port section.
If that does'nt work then:
Which plugin instrument are you using?
Are your DAW track armed and set to monitor?

Please search the controller forums and the web for more info about setting up a controller in Ableton Live. I think one in this forum for some reason had to reinstall Live to get it to work.
Essential this is what to do to set up a midi controller as midi controller in Live: https://www.youtube.com/watch?v=CWOXblksDxE

Terrym

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1.529
  • Karma: 40
    • soundcloud.com/logicaldream
Re: Keylab MkII VS ABLETON LIVE 10.1.7
« Reply #6 on: October 01, 2020, 11:11:19 pm »
Hi All
Just want to check that on the key lab pressing the DAW button until it flashes and selecting the DAW mapping for live  once done press the big knob
then if live is setup correctly you are good to go.
TerryM
ARTURIA Tester for Keystep pro,Audiofuse range, Microfreak,Kl49mkII,DrumBrute,Spark,Analog lab3,KLE,kl88,matrix12,Semv,Beatstep,Minibrute 2,Pigments
ASC,Vcol6, Beatstep pro, VCOL7, Synclavier v.Minibrute2s

Ciggie

  • Apprentice
  • *
  • Posts: 4
  • Karma: 0
Re: Keylab MkII VS ABLETON LIVE 10.1.7
« Reply #7 on: October 06, 2020, 08:18:13 am »
Hi and welcome to Arturia forums.

I don't use Ableton Live. You can try to check both Track and Remote in the MIDI port section.
If that does'nt work then:
Which plugin instrument are you using?
Are your DAW track armed and set to monitor?

Please search the controller forums and the web for more info about setting up a controller in Ableton Live. I think one in this forum for some reason had to reinstall Live to get it to work.
Essential this is what to do to set up a midi controller as midi controller in Live: https://www.youtube.com/watch?v=CWOXblksDxE

Hello and thank you for the response,

The track is armed in DAW, and I have done as you said, and even checked forums for similar issues, most of the problems I found were resolved as you mention, however in my case, and when checking Midi Control Center, the first fader for example is triggering both a G2 key, and a pitch bend, and the main chromatic keys do not trigger anything when monitored for midi activity.

It's strange to say the least.

Ciggie

  • Apprentice
  • *
  • Posts: 4
  • Karma: 0
Re: Keylab MkII VS ABLETON LIVE 10.1.7
« Reply #8 on: October 06, 2020, 08:19:28 am »
Hi All
Just want to check that on the key lab pressing the DAW button until it flashes and selecting the DAW mapping for live  once done press the big knob
then if live is setup correctly you are good to go.

Yeah this is already done, and it's not only in DAW more, even in Analog Lab mode, the same issue is prevalent, also in cubase.

LBH

  • Hero Member
  • *****
  • Posts: 3.765
  • Karma: 38
Re: Keylab MkII VS ABLETON LIVE 10.1.7
« Reply #9 on: October 06, 2020, 04:09:32 pm »
Hi and welcome to Arturia forums.

I don't use Ableton Live. You can try to check both Track and Remote in the MIDI port section.
If that does'nt work then:
Which plugin instrument are you using?
Are your DAW track armed and set to monitor?

Please search the controller forums and the web for more info about setting up a controller in Ableton Live. I think one in this forum for some reason had to reinstall Live to get it to work.
Essential this is what to do to set up a midi controller as midi controller in Live: https://www.youtube.com/watch?v=CWOXblksDxE

Hello and thank you for the response,

The track is armed in DAW, and I have done as you said, and even checked forums for similar issues, most of the problems I found were resolved as you mention, however in my case, and when checking Midi Control Center, the first fader for example is triggering both a G2 key, and a pitch bend, and the main chromatic keys do not trigger anything when monitored for midi activity.

It's strange to say the least.
Are you sure, that you use Port 2 for the control surface setup?  https://www.arturia.com/faq/keylabmkii/keylab-mkii-tips-tricks

Ciggie

  • Apprentice
  • *
  • Posts: 4
  • Karma: 0
Re: Keylab MkII VS ABLETON LIVE 10.1.7
« Reply #10 on: October 07, 2020, 10:15:34 am »
Hi and welcome to Arturia forums.

I don't use Ableton Live. You can try to check both Track and Remote in the MIDI port section.
If that does'nt work then:
Which plugin instrument are you using?
Are your DAW track armed and set to monitor?

Please search the controller forums and the web for more info about setting up a controller in Ableton Live. I think one in this forum for some reason had to reinstall Live to get it to work.
Essential this is what to do to set up a midi controller as midi controller in Live: https://www.youtube.com/watch?v=CWOXblksDxE

Hello and thank you for the response,

The track is armed in DAW, and I have done as you said, and even checked forums for similar issues, most of the problems I found were resolved as you mention, however in my case, and when checking Midi Control Center, the first fader for example is triggering both a G2 key, and a pitch bend, and the main chromatic keys do not trigger anything when monitored for midi activity.

It's strange to say the least.
Are you sure, that you use Port 2 for the control surface setup?  https://www.arturia.com/faq/keylabmkii/keylab-mkii-tips-tricks

Yes I am sure, and to add to that, the transport keys work perfectly, record button starts the record, play/stop button does exactly that, and after some fiddling, even the volume fader and pan knob work as intended.

Its just that the keys dont respond to anything, not on Live, not even in Analog Lab, which is Arturia's own product!

LBH

  • Hero Member
  • *****
  • Posts: 3.765
  • Karma: 38
Re: Keylab MkII VS ABLETON LIVE 10.1.7
« Reply #11 on: October 07, 2020, 01:12:19 pm »
If one of the Keylab setups in Lives MIDI setup is port 2, then try to swith it off. I can't see the full text on your image.
Only have the Keylab MKII on.

MIDI port 2 is used for the Control Surface setup in the section above the MIDI port setup section.

Unfortunately i don't use Ableton Live and i don't have an Arturia controller yet.
« Last Edit: October 07, 2020, 01:14:26 pm by LBH »

grahamsh

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
Re: Keylab MkII VS ABLETON LIVE 10.1.7
« Reply #12 on: November 26, 2020, 10:37:45 pm »
Hi and welcome to Arturia forums.

It sound like you have set the controller up to use it as a keyboard. That's good.

But have you also set it up as a DAW controller like you can see here:
https://www.arturia.com/faq/keylabmkii/keylab-mkii-tips-tricks
It does'nt sound like you have done this.

Notice the note about MIDIIN2 and MIDIOUT2 in Windows.

Hello,

I have done exactly as asked for in the link provided, but I am failing to get any results. Neither in Cubase, nor in Ableton.

Heres a screenshot from Ableton, what am I doing wrong? I can get the volume faders to work at best, but the keyboard is totally unresponsive. This happened after I re-formatted my laptop and installed Windows 10 again, the keyboard was working perfectly fine a week ago, before I formatted. In the first image, Remote is only on, the faders work, and there is no screeching sound.

In the second image, if I turn Track on, there is a screeching sound coming when I move the faders.

In both cases, the keys do nothing when pressed...

The transport controls work, such as arm the track, record, stop/play etc.

Ciggie

I truly hope that someone has helped you out on this already.

The cause of your problems is that you have both lines in your midi setup activated for the same things. They should be one on each column. ie

The first Keylab MkII input line should be set to Track    ----------This is used for the keys to send notes to the track
The second Keylab MkII input line should be set to Remote -------This is used by the sliders to send midi signals to the DAW

The screeching you hear when you use a slider is Ableton translating the midisignals to notes.

It is sad that nobody has given you this information earlier.


 

Carbonate design by Bloc
SMF 2.0.17 | SMF © 2019, Simple Machines