September 28, 2020, 07:44:57 am
Welcome, Guest. Please login or register.
Did you miss your activation email
News:

Arturia Forums



Author Topic: Simple Organ patch clicking/popping on Mac and Windows machines  (Read 141 times)

sooperdude

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
I've been getting weird popping issues with Analog Lab on both my Windows 10 machine and my Mac when playing on my midi controller - it seems to happen at random. Zero HD/CPU usage as monitored by Process Explorer and I'm using the VST3 on both systems.

Windows 10 is using an external Scarlett Focusrite audio interface with Focusrite ASIO drivers and FL Studio as my principal DAW and have never had any popping issues with other libraries such as Kontakt for example.

MacBook Air is using just standard CoreAudio with Reaper x64 as the DAW.

I tried rendering a very simple 8 bar sustained organ note on both systems using the "Mid Genesis" patch and you can here the popping in both rendered audio files. It's driving me CRAZY.


LBH

  • Hero Member
  • *****
  • Posts: 3.438
  • Karma: 36
Re: Simple Organ patch clicking/popping on Mac and Windows machines
« Reply #1 on: March 11, 2020, 09:26:08 pm »
Hi and welcome to Arturia forums.

Unfortunately i can confirm this issue. It's the same with the B3V2 plugin. It look like a B3 issue.
If i use realtime processing, then the issue is'nt there. So it look like an issue with fast rendering.

I use Windows 10, Studio One 3 professionel, VST2.

sooperdude

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
Re: Simple Organ patch clicking/popping on Mac and Windows machines
« Reply #2 on: March 11, 2020, 10:42:50 pm »
Hey LBH,

Thanks for the welcome. Any idea why hasn't this been addressed by Arturia?

I just tried a different preset, Bright Pop Layers and started to play on my midi controller. Once I had something I liked, I recorded the midi. On playback, it introduces a "high pitch squeak sound" consistently at the end of my first bar when I transition from Cmin to an Ab Major chord. IOnce again, the bug happens on both Windows + FL Studio + Focusrite ASIO, and on Mac + Reaper +
CoreAudio. It's a little more pronounced in the windows rendered file, but its pretty apparent in both. This... seems insane.

Attached both Mac and Win rendered files.
« Last Edit: March 12, 2020, 04:11:14 pm by sooperdude »

LBH

  • Hero Member
  • *****
  • Posts: 3.438
  • Karma: 36
Re: Simple Organ patch clicking/popping on Mac and Windows machines
« Reply #3 on: March 11, 2020, 10:50:26 pm »
I suggest you contact Arturia support about this issue.

 

Carbonate design by Bloc
SMF 2.0.13 | SMF © 2016, Simple Machines