May 29, 2020, 06:56:49 pm
Welcome, Guest. Please login or register.
Did you miss your activation email
News:

Arturia Forums



Author Topic: Midi rate wont send while in sync mode, Ableton  (Read 755 times)

donnner

  • Apprentice
  • *
  • Posts: 9
  • Karma: 0
Midi rate wont send while in sync mode, Ableton
« on: February 21, 2020, 06:34:13 am »
It seems the midi is working fine for all other configured midi parameters except for both the LFO and step sequencer's rate knobs, while in sync mode.
The configured parameters show my controller is sending the midi properly but the plugin doesn't respond at all.

(This seems to be the case for all three of the filters but i figure this one post will do?)
« Last Edit: February 21, 2020, 06:39:10 am by donnner »

LBH

  • Hero Member
  • *****
  • Posts: 3.146
  • Karma: 50
Re: Midi rate wont send while in sync mode, Ableton
« Reply #1 on: February 21, 2020, 06:03:03 pm »
Hi and welcome to Arturia forums.

It's great only to post one time, if the issue is the same.

The configured parameters show my controller is sending the midi properly 
Can you please explain this? What do you mean by configured parameters, and how do they show your controller is sending midi properly, and what is the controller in this case?

In a short test with the new versions, i don't seem to have any midi sync issues in my DAW Studio One 3 Professionel.

donnner

  • Apprentice
  • *
  • Posts: 9
  • Karma: 0
Re: Midi rate wont send while in sync mode, Ableton
« Reply #2 on: February 21, 2020, 08:34:01 pm »
In Ableton, each plugin has a group of “configured paramiters” that you can assign to most paramiters in a plug-in. Ableton shows you your “configured parameters” and if they’re responding properly and it’s definitely reviving the midi correctly from what i can see. I’m using an Apc40mk2 but i’ve also tried this with a Traktor F1 controller.
Also i should specify that it’s not that the program won’t keep its tempo in sync with my daw but rather, when you enable the beat synced rate controls and try to turn the corresponding “rate” knob while the “sync” switch is enabled, the midi ceases to turn for that one paramiter. If you then switch the rate sync off, the midi then works again. The mouse is still capable of turning the rate knob either in sync or free mode ofcourse, so it’s only not working under the condition that you’re using a midi controller and it’s set to sync rather than a free rate.
« Last Edit: February 21, 2020, 09:27:24 pm by donnner »

LBH

  • Hero Member
  • *****
  • Posts: 3.146
  • Karma: 50
Re: Midi rate wont send while in sync mode, Ableton
« Reply #3 on: February 21, 2020, 11:04:35 pm »
Then i think i understand.

Are you aware, that there is two Rate automation parameters - one for "sync rate "and another for "rate"? The sync rate work when sync is switched on, and the rate when sync is switched off. (I would like it was the same automation parameter, but it is'nt.)
It could look like you use the wrong parameters.

It also seems to work with my Novation Automap.

I have just tried to use Studio One 3's Control Link to do, what i beleive is similar to what you try to do in your DAW. It look like it work here, when i make a short test. I have'nt tested it all though.

Was it about that?
« Last Edit: February 21, 2020, 11:14:30 pm by LBH »

donnner

  • Apprentice
  • *
  • Posts: 9
  • Karma: 0
Re: Midi rate wont send while in sync mode, Ableton
« Reply #4 on: February 22, 2020, 04:59:35 pm »
Yeah, that seems be the answer exactly. I was unaware of the separate automation values.
Personally iím not sure i can see the reason for separating them, as it would be more intuitive to keep it the same regardless of the sync being enabled. It would also make it easier to go back and fourth between sync and free in a live scenario but a bug it is not. Thanks for clearing that up for me!
Perhaps this is more of a feature request then?

LBH

  • Hero Member
  • *****
  • Posts: 3.146
  • Karma: 50
Re: Midi rate wont send while in sync mode, Ableton
« Reply #5 on: February 22, 2020, 05:12:38 pm »
Good that was it, and it work.

Perhaps this is more of a feature request then?
Yes.

donnner

  • Apprentice
  • *
  • Posts: 9
  • Karma: 0
Re: Midi rate wont send while in sync mode, Ableton
« Reply #6 on: February 22, 2020, 07:18:54 pm »
Thanks a bunch!
One last question, should i remove this topic from here then, since iím gonna make a new one in feature requests? (sorry this is litterlaly my first topic post in this forum so iím not entirely certain 😅)

LBH

  • Hero Member
  • *****
  • Posts: 3.146
  • Karma: 50
Re: Midi rate wont send while in sync mode, Ableton
« Reply #7 on: February 22, 2020, 07:30:18 pm »
Your welcome.

It's fine to keep this thread. No need to delete it.

donnner

  • Apprentice
  • *
  • Posts: 9
  • Karma: 0
Re: Midi rate wont send while in sync mode, Ableton
« Reply #8 on: February 22, 2020, 07:39:05 pm »
👍

 

Carbonate design by Bloc
SMF 2.0.13 | SMF © 2016, Simple Machines