December 04, 2020, 06:19:19 pm
Welcome, Guest. Please login or register.
Did you miss your activation email
News:

Arturia Forums



Author Topic: KeyLab mk2 61 not responding to MIDI notes in Cubase 9.5 Pro  (Read 384 times)

MattGreer

  • Apprentice
  • Apprentice
  • *
  • Posts: 26
  • Karma: 1
KeyLab mk2 61 not responding to MIDI notes in Cubase 9.5 Pro
« on: January 21, 2020, 02:58:51 am »
No matter what audio driver/interface I use the Arturia software synths will not respond to keypresses from the mk2.

I have everything set to all/any midi channel.  Nothing works.

I have all MIDI ports visible:


None of these drivers works, it seems:


In standalone mode, the Creative ASIO drivers work.

Native Instruments has no issues with any driver selection; they all work in stanalone or in Cubase.

LBH

  • Hero Member
  • *****
  • Posts: 3.581
  • Karma: 36
Re: KeyLab mk2 61 not responding to MIDI notes in Cubase 9.5 Pro
« Reply #1 on: January 21, 2020, 04:37:19 pm »
I have a hard time to make any sense of this.

You have a lot of soundcard drivers, but they have to do with the soundcard you use. Which soundcard do you use? Which sample rate do you use?

Do you use the same controller when you play your NI plugins in your DAW as when you play your Arturia plugins? If so, then if the NI plugins work, then the Arturia plugins should too, if the routings and settings is the same.

In standalone mode keep in mind to set the Midi and audio settings in each Arturia application. It's described in the manuals.

Even if you set your Studio setup to ALL midi channels, then you still need to set correct midi channels for your controller and each of your tracks and plugins. In most cases everything work on midi channel 1, also in standalone mode.

If your settings are correct for both controllers, soundcard and routings, then things should work in al cases.

That's what i can do, with the availble informations.

I don't use Cubase.
« Last Edit: January 21, 2020, 04:43:30 pm by LBH »

MattGreer

  • Apprentice
  • Apprentice
  • *
  • Posts: 26
  • Karma: 1
Re: KeyLab mk2 61 not responding to MIDI notes in Cubase 9.5 Pro
« Reply #2 on: January 30, 2020, 12:19:11 am »
I reinstalled Windows 10 from scratch.  Patched to build 1903 (didn't really have a choice).  Installed the Soundblaster AE-5 drivers.  Installed and patched Cubase 9.5, installed the Arturia software and MIDI config software for the KeyLab.  Everything is up to date and using the latest and greatest drivers.

The only drivers that now appear from the list above are the two Soundblaster ASIO drivers and the Generic ASIO driver that comes with Cubase.

I can play the Arturia synths from within Cubase.  However, whenever I press one of the transport buttons, or one of the faders or knobs, I hear notes being played.  The Keyboard is set in DAW mode, to Cubase.  I added the Mackie Control and configured it according to https://www.arturia.com/faq/keylabmkii/keylab-mkii-tips-tricks  Currently, Cubase 9.5 does not have the option 'Use Metronome', only 'Activate Metronome'.

I am not using the Soundblaster card to record audio.  Just using the ASIO driver and the sound card is plugged into a speaker for monitoring.

Should I start a new thread for this issue?

LBH

  • Hero Member
  • *****
  • Posts: 3.581
  • Karma: 36
Re: KeyLab mk2 61 not responding to MIDI notes in Cubase 9.5 Pro
« Reply #3 on: January 30, 2020, 02:07:44 am »
Can you please post a screenshot of your Mackie Control setup in Cubase, and a screenshot of your Keyboard Controller setup in Cubase?
Did you see this: "Note: the ports are called MIDIIN2 and MIDIOUT2 on Windows" in this guide:
https://www.arturia.com/faq/keylabmkii/keylab-mkii-tips-tricks

Please also elaborate excactly what you mean, when you say, you hear notes.

And please confirm, that when you say DAW mode, then only the DAW button is active on your Keylab Controller.

MattGreer

  • Apprentice
  • Apprentice
  • *
  • Posts: 26
  • Karma: 1
Re: KeyLab mk2 61 not responding to MIDI notes in Cubase 9.5 Pro
« Reply #4 on: January 30, 2020, 04:07:04 am »
I made a video, hopefully this will help illustrate what my settings are as well as the issue I'm having.  Thank you again for your help!

https://youtu.be/fzptOz69mh4


LBH

  • Hero Member
  • *****
  • Posts: 3.581
  • Karma: 36
Re: KeyLab mk2 61 not responding to MIDI notes in Cubase 9.5 Pro
« Reply #5 on: January 30, 2020, 04:52:13 pm »
I don't use cubase and i don't have a Keylab controller.

The transportbars start seems to work at first. But yes i can hear some sounds in your video.
And i can hear sounds for a few sliders, but not all.
In generel, yes i hear the sounds. The question is what the cause is.

As an exsperiment to find out what is going on, i would like you to try to deactivate the MIDIOUT2 in cubase.
You have it on both the Mackie and the keyboard setup. Try to deactivate it first in the keyboard setup only, then for both, and then for the Mackie setup only.
Does any of those settings remove the incorrect sounds?

When your controller is in DAW mode, then the sliders should control channel faders in your DAW, i believe. Do you see the DAW faders move?
I notice that not all sliders create a sound.
What is the instruments you have loaded? Cubase's internal instruments?

MattGreer

  • Apprentice
  • Apprentice
  • *
  • Posts: 26
  • Karma: 1
Re: KeyLab mk2 61 not responding to MIDI notes in Cubase 9.5 Pro
« Reply #6 on: January 30, 2020, 07:57:29 pm »
The reason the transport bars seem to work at first is because the drum track was selected so the sounds are low and just one hit so you can't hear them over the click of the transport.

Sorry you don't have Cubase or this keyboard.  I appreciate that you're trying to help.  Tech support has not responded to my original request since Monday.  I submitted another request after I did the clean install and they merged the two, but no update.  So I don't know what to do other than to return the keyboard before the grace period expires.

The faders that made a sound were the ones attached to channels.  Faders not attached to channels don't make sounds.

I'm pretty certain the issue is in the MIDI setup but I've tried different combinations of selected and not selected to no avail.  I'll try to come up with all the pertubations and combinations of the selections to try to nail down what's going on.  I'm at work at the moment so I can't work on this but I will when I get home.

I was using Cubase's internal instruments at that time.  The response is the same if I attach an Arturia instrument to a track.

Thank you again for your continued suggestions!

LBH

  • Hero Member
  • *****
  • Posts: 3.581
  • Karma: 36
Re: KeyLab mk2 61 not responding to MIDI notes in Cubase 9.5 Pro
« Reply #7 on: January 30, 2020, 09:25:10 pm »
Your welcome.

My guess is it's about the MIDIOUT2 in your keyboard controller setup, should be set to inaktive instead of aktive.
If a midiout should be active there, then i would guess it should be another than MIDIOUT2.

MattGreer

  • Apprentice
  • Apprentice
  • *
  • Posts: 26
  • Karma: 1
Re: KeyLab mk2 61 not responding to MIDI notes in Cubase 9.5 Pro
« Reply #8 on: January 30, 2020, 09:39:25 pm »
I received a reply from Arturia tech support:

Quote
The note is due to the fact that you have enabled the Midiin2 in the all midi collumn, deselect it and it would operate as it should,

So it looks like you and tech support are on the same page.

I would like to think I missed this in the installation and configuration manual/options somewhere, but I never saw anything relating to how the MIDI In/Out, and not just a "MIDI Device" (aka Mackie) should be set up.

OK, I would like to leave work early but I cannot!  :)

Dragon Venom

  • Apprentice
  • *
  • Posts: 3
  • Karma: 0
Re: KeyLab mk2 61 not responding to MIDI notes in Cubase 9.5 Pro
« Reply #9 on: February 02, 2020, 08:49:45 am »
Although you already have a solution to your issue, I thought I would give you a bit more information on the subject that might help. I am a Keylab MK2 user and a Cubase Pro 10.5 user. There are actually a few ways to control the note on sounds you were hearing. The easiest is exactly what tech support told you. Remove the MIDI2 port from the "all MIDI" column and it will go away. Another way is to select the Keylab directly. You can do this from the inspector in Cubase on the left-hand side of the screen. With any MIDI or instrument track selected you should see the out port listed as "all MIDI" if you change this to keylab it will stop the note sound for that specific track. When you de-select the MIDI2 port in the Studio panel, you are actually doing the second method for every track automatically.
Next, you mentioned there was no metronome setting named as the one in the setup document. This is correct, but more importantly, the setup document is only a "recommendation" for what you should enter into the Mackie setup panel. You can customize the buttons on the Keylab front panel simply by changing the Mackie panel to reflect whatever functions you want those keys to perform. If I recall, the only button that is "hard mapped" is the set punch out button. If you don't need to constantly enable and disable the metronome for example, you could configure the metronome key to pull up the VST instrument for a track or automatically render a midi or instrument track direct to audio with just a push of that buttom. This is a quick way to map a few keys without going into full user mode and creating a complete MIDI map. On the control surface area, the upper row of buttons are static and cannot be changed without going into user mode, but the lower row is fully configurable except for the one "punch out" button.
Hope that helps and gives you ideas to make your workflow more productive.

Marinoter

  • Newbie
  • *
  • Posts: 1
  • Karma: 0
Re: KeyLab mk2 61 not responding to MIDI notes in Cubase 9.5 Pro
« Reply #10 on: February 19, 2020, 11:44:33 am »
Do please check on track parameter "midi in" is set to the mkII instead of "all midi inputs"

 

Carbonate design by Bloc
SMF 2.0.17 | SMF © 2019, Simple Machines