January 25, 2020, 08:47:25 am
Welcome, Guest. Please login or register.
Did you miss your activation email
News:

Arturia Forums



Author Topic: NI Komplete S49 vs. Pigments is sending unknown midi  (Read 86 times)

pehbos

  • Apprentice
  • *
  • Posts: 3
  • Karma: 0
NI Komplete S49 vs. Pigments is sending unknown midi
« on: January 12, 2020, 12:35:32 pm »
Hi altogether,

I purchased Pigments and I am really happy with that virtual synth. But I have a huge Problem using Pigments with my Komplete S49 Masterkeyboard. When I am playing notes all is just fine. But when I am using the control buttons on S49 there is some midi sent out and changing the sound of pigments. I could not figure out what midi that is. The sound will bekomme as if it is an octave higher or the cutoff is being opened. I also can see that i.e. when using a preset there is a star after the name - so there was definetivly a change.

I tried using Pigments as a plugin on its own as well as in Komplete Kontrol - the same Issue. It is mostly when using wavetables and really annoying.

Someone has the same problem or am I the problem? I really appreciate your help on that topic, working under that circumstances with pigments really doesnt make fun at all.

I am running Pigments in Ableton live 10 (no suite) / Cubase Elements 10 on Windows 10 Intel I5 and Focusrite 18i8

Thank you in advance,

Sebastian
« Last Edit: January 12, 2020, 12:37:14 pm by pehbos »

LBH

  • Hero Member
  • *****
  • Posts: 2.707
  • Karma: 50
Re: NI Komplete S49 vs. Pigments is sending unknown midi
« Reply #1 on: January 12, 2020, 01:57:18 pm »
Hi and welcome to Arturia forums.

It look like your midi controller send some midi CCs that some parameters in Pigments is set to use. That's normal.

Which midi CC numbers are the buttons that change the sound in Pigments set to use?
Why do you use the buttons, if you don't wan't to change anything?

I don't have a NI keyboard.

pehbos

  • Apprentice
  • *
  • Posts: 3
  • Karma: 0
Re: NI Komplete S49 vs. Pigments is sending unknown midi
« Reply #2 on: January 12, 2020, 02:16:17 pm »
Hi and thanks for welcoming and thanks for your reply.

The problem is I am not hitting any other button than the transport buttons for recording. Should be possible to use them without changing the sound.

Furthermore the change isnt triggered directly. The change applies after a few seconds, without using any key of the controller.

Is there maybe something like a "midi watch" that shows every triggered midi note? Maybe I can see what is going on then.

Greetings

LBH

  • Hero Member
  • *****
  • Posts: 2.707
  • Karma: 50
Re: NI Komplete S49 vs. Pigments is sending unknown midi
« Reply #3 on: January 12, 2020, 02:41:42 pm »
If the transport buttons does'nt send any other messages than MCU or HUI messages to your DAW, then they don't do anything in Pigments.

Furthermore the change isnt triggered directly. The change applies after a few seconds, without using any key of the controller.
This sounds like you have some automation going on in your DAW. I assume you start the DAW with the transport buttons, and after a while the automation step in. Have you checked that?
Look at the automation in your DAW-


Also the sound you use can have some modulation going on. Do you use a Factory preset in Pigments - if so which?
Do you hear changes in Pigments default preset?


Is there maybe something like a "midi watch" that shows every triggered midi note? Maybe I can see what is going on then.
In Pigments you can see the played notes on the virtual keyboard. And the modulations can be followed in the Center modulation strip. The rest is about your DAW.
Do you know how to use your DAW Ableton Live?

pehbos

  • Apprentice
  • *
  • Posts: 3
  • Karma: 0
Re: NI Komplete S49 vs. Pigments is sending unknown midi
« Reply #4 on: January 12, 2020, 02:55:09 pm »
Hi thanks for your reply,

when starting with a complete empty project there is no automation in the DAW, when bringing in a new and only one midi slot and loading Pigments. Thats the reason why I am asking, I did not set up any automation as well as there is not an existing recorded automation. You can not see anything in the piano roll as well as some files inside the pattern (extended envelope recording every midi trigger).
There are definetifly changes in sound, noticing this in the starblinking up at the end of the preset name, beside the obvious sound changing what I can hear.

I know how to use ableton. It also appears in Cubase so it has definetifly to something with NI Komplete I assume now.

Greetings,

Sebastian.

LBH

  • Hero Member
  • *****
  • Posts: 2.707
  • Karma: 50
Re: NI Komplete S49 vs. Pigments is sending unknown midi
« Reply #5 on: January 12, 2020, 04:38:36 pm »
Hi. Your welcome.

so it has definetifly to something with NI Komplete I assume now.
I think that very well can be the case in some way or another.

Pigments has it's own internal modulations, but as you describe things, then the modulations is coming from putside Pigments, and Pigments only react to that, if midi CC messages is being sent to it.

Cheers

 

Carbonate design by Bloc
SMF 2.0.13 | SMF © 2016, Simple Machines