Arturia Forums

Controllers => MiniLab MKII => MiniLab MKII Technical Issues => Topic started by: cptncvmn on February 13, 2019, 04:59:29 am

Title: Analog Lab 3 + Minilab MKii - Midi Mapping in Logic Pro X. GRRRRRRR!
Post by: cptncvmn on February 13, 2019, 04:59:29 am
I have scoured the internet for an answer to no avail.  Admitted novice with midi mapping, but for the life of me, can't find an answer on how to get the AL3 AU plugin in Logic Pro X to work the way AL3 does in standalone mode.  Arturia support has proven worthless thus far.  Is there a script/automated way of doing this? (I get the sense there isn't).  If the only solution is manual mapping, can anyone provided detailed instructions?  Even better, a youtube video tutorial specific to the ML MKii would get you good karma for life!

Below is an email chain between myself and Arturia support describing the problem a bit more.


When in standalone mode in Analog Lab, the minilab's controller assignments work perfectly. However, in logic, the default mapping is completely illogical and not at all like that in analog lab (where the knob/pad you adjust on the physical controller turns the same parameter on the 'virtual' controller onscreen).
Admittedly, I'm new to logic and don't know how to manually route the settings, particularly for every virtual instrument in AL3 (if that's even a thing). Is there a 'plug-and-play' script/setting/whatever that I can 'drop' in logic such that the controls will emulate those in standalone AL3?
I see that for the keyLab there's a an option in the midi control center to set the DAW as Logic. But no such thing exists for the minilab.
I'm frustrated and stuck. any help would be greatly appreciated, the more detailed the better.

Basically, the mappings should be the same than in standalone, and you shouldn't have to configure anything for having them to work.

1. Please confirm that the MiniLab MkII is selected on Analog Lab 3 interface > MIDI Controller:
2. Make sure that the MiniLab MkII is either:
- Not enabled as a control surface in Logic
- That none of the MiniLAb controls have been mapped in Logic MIDI assigment

I have checked all settings are as you said but Iím still confused.   

Iím referring to the Analog Lab 3 AU plugin INTERNAL to logic.   When no other software is running, I go into logic and select Ďsoftware instrumentí-> Instrument->AU Instrument->Arturia->Sound Lab 3->Stereo, the plug-in pops up.  But because Iíve disabled the Minilab as an input device, when I hit a key on the minilab, nothing happens. This would make sense because Iíve disabled it as a input device but I know itís capable of producing sound b/c if I click in the plugin on a key with my mouse, it produces a sound.  Conversely, when I enable it as an input device, it does Ďworkí but again the mappings are all off and Iím back where I started. 

If AL3 was capable of running as a rewire device, your instructions below would make more sense to me.  Can you please clarify that your instructions below are for AL3 as an AU instrument and if not, what configuration are you speaking of?

Can you please provided step-by-step instructions (like you were talking to a novice) from the first step on how I can use AL3 in conjunction with Logic and have the mappings be consistent.

I apologize if Iím simply missing it, but itís still not making sense to me.

Title: Re: Analog Lab 3 + Minilab MKii - Midi Mapping in Logic Pro X. GRRRRRRR!
Post by: MajorFubar on February 13, 2019, 12:49:28 pm
Arturia have in fact given you good advice. For a start, they didn't say disable your MiniLab as an input device: they said disable it as a control surface. Logic recognises the MiniLab as a control surface and maps some of its physical controls to its own internal smart controls, overriding the mappings of the Analog Lab VST.

I'm at work at the moment, but if time allows I'll have a look tonight at the mappings on my own setup, which is broadly similar to yours (Logic 10.4 + Analog Lab) but with a LayLab 88 not a MiniLab.
Title: Re: Analog Lab 3 + Minilab MKii - Midi Mapping in Logic Pro X. GRRRRRRR!
Post by: cptncvmn on February 13, 2019, 03:44:44 pm
Ahhhh... I'm not sure why this didn't work the first time.  But based on your feedback, I went back in and double checked the settings.  Upon 'deleting' the MKii as an option under 'controller assignments', the correct mapping took effect.  I swear I did this before and it didn't work but clearly I didn't do something correct. Thank you for checking me on that.