Arturia Forums

Software Instruments => Modular V3 => Modular V3 - Technical issues => Topic started by: gphantom on September 30, 2018, 03:33:27 am

Title: Latest version screw up with Ableton Live 10 Intro
Post by: gphantom on September 30, 2018, 03:33:27 am
An issue with Ableton Live Intro 10 is the Modular V version 3_3_3_0_1391 where the interface is so large that it is un-usable AND no plugs are available etc.  Obviously, someone changed something in versions 3_3_2 of AL3 and 3_3_3 of Modular V which screwed things up.
After re-installing MODULAR V version 3_3_2_1_1217, everything is fine.

I am no longer going to update any versions of any Arturia Software if a current version works.  I should know by now that "IF IT AIN'T BROKE, DON'T FIX IT!!!"
Title: Re: Latest version screw up with Ableton Live 10 Intro
Post by: LBH on September 30, 2018, 12:31:44 pm
Can't you resize thru the menu?
Title: Re: Latest version screw up with Ableton Live 10 Intro
Post by: gphantom on September 30, 2018, 09:29:57 pm
No menu, just the background image without the dials or patch cords or buttons.  Usually, you would display a single background image and then, display the knobs for the module you setup.  No module, no display (i.e. ADSRs)
I'm going to check out other things.  Right now, seems that things work best with Windows 7 but not Windows 10.  Who knows, it might be window all along.
Title: Re: Latest version screw up with Ableton Live 10 Intro
Post by: LBH on September 30, 2018, 10:50:32 pm
FWIW i use Windows 10 latest version and update. I have no such issue with Modular V3 latest version.

I do remember i in an update have had to resize an application because the setting was'nt the same as before the update. It was max size. But i could just resize thru the menu either in standalone mode or in plug-in mode, but i think i could'nt in one of those modes. Or perhaps i changed the size in the pref xml file of the application, and then been to get to the menu afterwards. Can't remember.

What have you tried to do?
Can you post screenshots to see the applications and the elements that's missing? It could be a graphic driver that need to be updated or so, but i understand you have other Arturia applications that work.  But perhaps a thing to check if it's possible to update. But it's possible you have checked this allready.
Title: Re: Latest version screw up with Ableton Live 10 Intro
Post by: gphantom on October 01, 2018, 05:21:28 pm
So far, it does appear that Windows 10 is the culprit.  I have all updates so there's no issue there.  I have two screens and noticed that when I try Modular V 3 with Ableton Live 10 Intro, the Modular V 3 background image takes up both screens in size.  Disabling one screen and the background image takes up only 1 screen.  Tried reducing the resolution of my display - Nothing.  Tried using version of Modular V and the background image is displayed with some patch cords but the plugs are off-center as well as the dials and no sound available.  I got AL3 latest version to finally work ( but, B#1, B1, C2, C#2 and C5 don't work (I have the Keylab Essential 49 but when going one octave up, C5 and above don't work - CRAZY)

Booted up windows 7 (Same machine, one SSD for XP, one for Windows 7 and one SSD for Windows 10 so bootup is fast enough for me to switch often if needed)
Tried AL3, versions and the previous version - No problems at all
Tried Modular V and - No problems at all.

TADA!!!!  Windows 10 has a problem with driver handling.  My display card is a Sapphire AMD HD6670 with 1Gig memory and in Windows 10, I tried downloading a previous driver as well as the one that Microsoft makes available as a default.  Nothing.  Therefore, the core Windows 10 driver handling causes a problem between the sound card and/or USB port (for Keylab Essential) and/or the DIsplay card.  (Explains why only background images are displayed full screen and the software can't plug in the dials/patch cords etc.  An interrupt is probably hanging up and the software can't continue since it didn't receive a go ahead)

My next step will be to change my display card to see if anything changes.  As soon as I get some money.
Title: Re: Latest version screw up with Ableton Live 10 Intro
Post by: LBH on October 01, 2018, 07:20:54 pm
I assume you allready have tried to un- and reinstalled Modular V3. That often helps.

Perhaps Windows does'nt show the correct availble drivers for you graphics.
Have you tried to use AMDs driver detect for a Windows 10 driver?

I got AL3 latest version to finally work ( but, B#1, B1, C2, C#2 and C5 don't work (I have the Keylab Essential 49 but when going one octave up, C5 and above don't work - CRAZY)
AL3 latest version now suddenly work on Windows 10? How?

I don't have Keylab Essentiel. Does it work corect with other plug-ins?

Title: Re: Latest version screw up with Ableton Live 10 Intro
Post by: gphantom on October 04, 2018, 01:39:06 am
Well, you didn't read everything in my post since I did state that I installed one version, installed another and then another still for both AL3 and Modular V3.  After re-installing different versions of AL3, the last time I installed the latest version, it was accepted by Ableton.  That's how I got AL3 to be recognized by Ableton.  The same goes for Modular V3 though I should have tried V2 but I stayed with V3.  Modular V3 doesn't load into Ableton using Win10 and yes, I used the drivers for my video card and the one that Windows uses by default.
Other plug ins also have problems, especially with B#1 through C#2 and C5 and higher but, the displays seem to work fine.

Too many drivers, so little great programmers.
Title: Re: Latest version screw up with Ableton Live 10 Intro
Post by: LBH on October 04, 2018, 03:02:05 pm
Ok - so your answer to my "How" question must be, it was luck (?), - and that the issue with AL3 was a install issue of some kind on your computer, even if you have blamed other things in your posts. It apparantly was'nt a Windows 10, a driver or a graphic card issue. Or was it anyway?
And as you have the same issue using both one and two displays, then the use of two displays apparantly has nothing to do with the issue either. Or has it anyway? (It could have had.)

But if you only have issues with Modular V3, and a clean un- and reinstall of Modular V3 does'nt fix the issue, then why do you have issues at all? Arturias installers do fail. Sometimes i think to often. But i don't think i have ever seen that it was needed to un- and reinstall so many times. Normally a single time is enough, if it's a Arturia install issue. (Modular V2 and V3 are two different applications.)

I use Modular V3 on two fully updated windows 10 64 bit systems using intel 4000 graphics. So it can't be a generel issue with Windows 10 or Modular V3 on Windows 10. Can it?
And i believe your graphics should support all Arturias VC applications too, at least with updated AMD windows 10 compatible drivers. Don't you think so?

Are you using Ableton Live 10.0.3? I believe some things with Arturia Analog Lab should be fixed in this version. So if you only have issues in your DAW, then that's a thing to try.
I have Ableton Live lite 8 32 bit installed on one of my computers, and there is no issues with VST2.4 version of Modular V3s GUI when loading inside that DAW. I can't test more than this with Ableton Live.
If the issue also excist in standalone mode, then it does'nt look like it's a DAW related issue. Does it?

Could the issue be about your computer setup? I guess it could. Is there something that can mess up an install?

Is the issue a mystery, that only can be solved with luck?

Just trying to help. But perhaps you don't look for user help. I understand and know an issue like this can be frustrating.
Title: Re: Latest version screw up with Ableton Live 10 Intro
Post by: gphantom on October 06, 2018, 11:18:18 pm
Probably a language difference, which is understandable or, what's in my mind isn't being translated properly.
I am an applications/Software engineer and have written programming languages in Assembler, Forth etc so, I know how an interrupt driven operating system works which is why I am saying that there's probably a problem between Windows 10's handling of interrupts and that of my display card drivers.  Windows 7 shows no problems with my display card, the Sapphire card (Not necessarily the top of the line card.)  Windows 10 is an upgrade to Windows 7 on my system so Win10 built on Win7.  Maybe if I perform a direct install of windows 10 instead of upgrading from windows 7, things might behave differently though I don't think so.

WINDOWS 10 discussion.  WINDOWS 7 = No problems
-  Why did AL3 became recognized when re-installed?  Who knows.  Luck?  There's no luck in computers... Computers do what they feel like doing (Again, due to an interrupt driven machine, things have to happen in the right sequence sometimes, which is why you can re-install something and all of a sudden, it works.)
Why does it change with two versus one display?  The software asks the system what the screen width is so, if you have two screens, it calculates the width of both screens side-by-side.  If you disable one screen, the system reports the width of the viewing screen only which dictates the width of the image displayed.

- The installs, re-installs of Modular V3 (and AL3) are because I was testing different versions.  I keep all versions that I download in case I have to go back to a previous version or refer to an older version.  For Modular V3, I have versions 3_0_2_98, 0_4_1092, 1_0_205 all the way to  3_3_0_1391.  I also have versions  2_6_3,  2_7_0,  2_7_3_765 and 2_8_0_76
When I have a few minutes and am in Windows 10, I will probably try the Version 2 of Modular V to see if the symptoms are the same.
The reason I suspect an incompatibility between Windows 10 and my display card is that version 3_2_1_1217 of modular V3 is almost properly displayed but stops when several patch cords are displayed but the plugs themselves are offset.  This usually means that an interrupt hasn't completed and the software is waiting for the interrupts to return an OK signal or the software just waits.  Since physical interrupts 9 through 15 pass through interrupt 2, this means changing the vectors for INT2 in order to determine where the interrupt is from, whether from an INT2 device or the sub interrupt chips 9 though 15.  Also, windows uses virtual interrupts which eventually passes through (I assume) the software interrupt vector.  When the display card's drivers are loaded, they replace the windows interrupt vectors with it's own.  With all those interrupts, all you need is one mis-behaved driver to throw everything out of whack.
The problem with Ableton 10 (not a real problem but possibly an inconsistency) is that it probably relies on software interrupts in order to make use of the VSTs which means that if the display driver isn't cooperating properly and returning the correct signals, it can cause the problems I'm seeing.  Why I'm inclined to think that there's a problem with Window 10, is because Windows 7 has no problems with Ableton 10 and AL3 and Modular V3.
To see if there's a problem with the way Ableton 10 is processing the interrupts, I'll check to see if the same problem occurs with Ableton Live 9 Lite.  If it works with Live 9, then Live 10 has changed something and is not cooperating with the drivers for my display card.

- Ableton Live 10.0.3 is what I'm using and as I mentioned, the very same software running in Windows 7 works, where it doesn't in Windows 10.
The other reason why I'm led to believe that it's a driver issue is the problems with the MIDI controller and keys B#2, B2, C3, C#3 and everything above C5 not responding (Though this is a crazy problem since the same interrupts are occuring but only specific keys are not)
As far as graphics cards go, I use X-plane flight simulator (FAA certified for flight training) and I load it down with high res graphics and objects and it does work without a glitch.

-  I welcome anyone's input no matter how simple it might sound because often, the simplest solution is the one that works (Murphy's law)
Your texts have made me think of trying Ableton 9 to see if there are also issues with it so, all questions and solutions proposed are fine.

In any case, I'll keep you up to date as I try other tests.

Title: Re: Latest version screw up with Ableton Live 10 Intro
Post by: LBH on October 07, 2018, 01:38:15 pm
Hi gphantom,

Thanks for your friendly post.
No doubt i could and should have chosen better and more precise words than "How?". Like asking why the many AL3 reinstalls helped, as that was what i meant.

Unless Modular V3 work

Unless Modular V3 have other system requirements than all other V-Collection applications, then it look like it should run as well as any other VC application on your PC, in Ableton Live 10, on Windows 10 and using the graphics, drivers and BIOS settings you have now.
And if so, then it does look like it could be a Modular V3 install issue. Are you sure all traces of every previous Modular V versions is removed, when you un - and reinstall it?

I assume you have tried to rescan plug-ins in Ableton, and that you have checked the plug-in has the correct date. Otherwise it might be worth to do.

But perhaps something strange is going on.
You can ask Arturia if Modular V3 have other requirements.

I don't think, i can add more. At least not now.

Good luck with your testing.

Title: Re: Latest version screw up with Ableton Live 10 Intro
Post by: gphantom on October 08, 2018, 10:37:01 pm
Well, I got results from the Ableton team and this is what they wrote:

This issue sounds like there is something going on with High DPI support on Windows 10 and the plugin, in conjunction with the host (Live).
We know that Arturia had some issues with that recently and the screenshots look like it is more of an "Arturia only" problem, to be honest.
When it comes to our end we fixed all bugs related to High DPI user interfaces (presumably).
You can check out the latest Beta by downloading it here.
Should the error still persist I'd assume there is something fishy with the plugin. Should it be fixed by the Beta that would be also nice to know.
Please note that Windows 7 doesn't really support high DPI screens and works a lot different than WIndows 10 in this regard.
You can't compare them side by side.

I'll try their beta  version to see if anything changes and if so, will report back to them and here.  Let's hope.
Title: Re: Latest version screw up with Ableton Live 10 Intro
Post by: gphantom on October 09, 2018, 05:48:54 pm
I tried the beta version and everything is the same.  However, it appears that it is Windows 10's High DPI that is causing the problem.  I did find a way to disable this feature but, it applies only to a single application.  If more apps mis-behave, you need to disable everyone individually.

Right click on the shortcut or the .EXE itself (Ableton Live shortcut).  Click on "Properties" then select the "Compatibily" tab.  Click on "Change high DPI settings" then select the two option boxes then click OK to solve the problem.  However, I'm still having a problem with the plug-ins whereas the B#1, B1, C2, C2# A4 keys and everything above C5 where they don't play a sound although the virtual keys on AL3 and Modular V3 do function.  They do work on the standalone programs.
One problem down, one to go.