Arturia Forums

Software Instruments => V-Collection => V Collection 6 - Technical Issues => Topic started by: Tausendberg on March 02, 2018, 01:25:10 am

Title: VST 2.4?
Post by: Tausendberg on March 02, 2018, 01:25:10 am
Hey, I have a bit an issue with my DAW where it doesn't do what I want it to with VST3's (presonus studio one apparently won't pass through polyphonic aftertouch to VST3).

So, what can I do to load up v collection as VST 2.4?
Title: Re: VST 2.4?
Post by: LBH on March 02, 2018, 03:29:04 am
I only have channel aftertouch. I actually don't know which if any off Arturias applications support Poly Pressure. Perhaps Arturia can step in here and tell?

Also in this thread from Presonus Forum - Niles who usually is very well into the Studio One stuff write that Studio One does'nt support Poly Pressure. badsearcher  claim he has got it to work with an old Modular V or V2 VST2 version. But i have not read it all, and i don't know what works or not regarding Poly Pressure. If it works, then t perhaps require more tracks in S1, and only on MIDI channel 1, as i believe that's how for example a ROLI Keyboard can work in S1.
All of this you perhaps have to find out somehow.

If you find out the above, then i'm interested to know the answer for sure.

Regarding VST2 and 3 versions in S1.
Arturias VST2 and VST3 versions of a plug-in share the same ID. When that's the case then Studio One give VST priority (EDIT (VST3 priority) EDIT END). Because of this you unfortunately can't have both the VST2 and the VST3 version of plug-ins with shared ID's availble at the same time in S1.
You can either do this before you open S1:
1. Delete the S1 path to your VST3 folder - then none VST3's are loaded but only the installed VST2's.
2. Remove the individual VST3 plug-in from your VST3 folder - then the installed VST2 version of this plug-in is loaded.
Off coarse you can choose to not install VST3's.
Title: Re: VST 2.4?
Post by: Tausendberg on March 02, 2018, 04:21:35 am
It's not super advertised but I'll tell you right now, if you load up a poly patch of modular v or a poly patch of cs-80v in a standalone instance of either of these vsts and then use a Roli Seaboard Block to play polyphonic aftertouch with it, then poly at works perfectly in the vsti (and it's awesome!) So that's why I feel it's very urgent to get a workflow for getting this into my compositions.
Title: Re: VST 2.4?
Post by: LBH on March 02, 2018, 04:56:56 am
What happens when you record? Does the Poly Pressure work using only one track in S1?
Title: Re: VST 2.4?
Post by: Tausendberg on March 02, 2018, 05:21:01 am
Nothing happens in Studio One when I use polypressure, I have to play in standalone in order to play with poly aftertouch.
Title: Re: VST 2.4?
Post by: LBH on March 02, 2018, 06:22:55 am
Thanks for reporting back. That's not too useful then.

I have just been in S1 forums. It look like it's you reporting a S1 bug there regarding VST3, as it don't work like a VST2 does. (But in S1 forum the VST2 is reported to work with Poly pressure in S1 except from recording. Is this correct?)

Have you seen that a Arturia VST2 in S1 also give the possibility to set MIDI channels in a way a Arturia VST3 does'nt? Steinbergs VST3s does have this option in S1. So i think this can also be about Arturias VST3's functionality, that need to be improoved. I don't own any VST3 that have this functionality, but a trial from Steinberg have. So it look like it's about how the VST is coded.
I have reported this a long time ago, and i still hope Arturia will fix it, as it does look like the plug-in coding does'nt implement VST3 functionality. VST3 should even be able to accept multiple MIDI channels at the same time. (Useful for any plug-in like B3 V a Matrix V2 that can operate with multiple MIDI channels at the same time for the manuals or the sounds.)

Arturia is this functionality issues a VST3 plug-in coding issue from your side? Would be nice if you answer this question.
Will you do anything about it?
Title: Re: VST 2.4?
Post by: LBH on March 02, 2018, 02:30:45 pm
I guess the thing i mention about VST3 and multiple MIDI inputs at the same time perhaps can have to do with how S1 handles controllers and does'nt have a OMNI setting.
But still you should be able to select a single MIDI channel for Arturias VST3s as you can for Steinbergs VST3s, i would say.

But i don't know why there are this differences.
It look like there can be some things with both S1 and the VST3 plug-ins.
BTW: Have you tried if you can play Poly Pressure with Arturias VST2 versions of Modular V3 and CS-80 V3 in S1?

It would be nice to get officiel info about all this.
Title: Re: VST 2.4?
Post by: Tausendberg on March 02, 2018, 08:50:53 pm
Where do I have the choice in V collection or Arturia Software Center to only install VST2's?

I would really like to get rid of the VST3's because they have only been problems.
Title: Re: VST 2.4?
Post by: LBH on March 02, 2018, 09:33:46 pm
When running the installer you can uncheck the plug-in version, that you don't wan't to be installed.
If you install thru ASC, then i believe you can have the installer to pop up, if you uncheck "Silent Install".

But you also have the options i wrote about in my first post.
Title: Re: VST 2.4?
Post by: Tausendberg on March 02, 2018, 10:11:20 pm
Awesome, that worked! And now I have poly aftertouch inside Studio One.

I guess this can be an interim solution until Presonus actually decides to fix their midi integration.
Title: Re: VST 2.4?
Post by: LBH on March 02, 2018, 11:09:22 pm
Yes but i think it's best to say, that Presonus Studio One does'nt support PolyPressure as it is. It can't record PolyPressure MIDI data and can't play then back either.

And as i understand you, then you use a speciel connection to let the PolyPressure be passed on to a VST2 inside S1, and it's not possible to do with a VST3.

Have you actually tried to record a audio track directly using PolyPressure in Studio One? Afterall the data needs to be processed. It look like it can, but needs to be done to be certain.  Can Studio One do that? Or can you just play with PolyPressure inside Studio One and nothing else?