Arturia Forums

eLicenser protection system => Users' corner => Topic started by: stuart on July 30, 2012, 03:02:21 pm

Title: intermittent elicenser
Post by: stuart on July 30, 2012, 03:02:21 pm
Hi all.

I am having issue with my elicenser in that it is very intermittent. Sometimes when i open up any of my Arturia products it asks me for my activation code. I have set this all up and when it works its fine. This is my 2nd elicenser as the first one just gave up on me. I have since bought the V3 collection so have purchased and elicenser from Steinberg as now i Have 2 versions of some synths, so my plan is to separate the licenses onto different keys so I can use them on different computers. The problem still is that my original elicenser is intermittant.

I boot up pro tools which has a few Arturia synths and my Arturia plug ins say that they are not activated. At first though i assumed it was my hub, but I have an ilok and a Reason dongle also attached and they are not affected.

To resolve the issue with the elicenser I have to remove it and plug it back in, it then reads the keys and everything is ok.

Anyone have this intermittently with their elicenser 

Attached pic of how I connect
From left to right it is: elicenser, Reason dongle, ilok, Avid C 8, Spark and Avid Eleven rack.

I also have the XILS 3 on the elicenser which also gives me errors occasionally so my thoughts are that the elicenser is at fault.


Title: Re: intermittent elicenser
Post by: stuart on August 01, 2012, 02:23:39 pm
OK, so further testing is suggesting that the dongle has some kind of odd timeout issue when connected to USB.

Here are two screen grabs form my system profiler. Number 1 shows my USB devices about 20 minutes after I booted my mac, I then launched Pro Tools and Reason to see if I get a authorisation error with their dongles, and nothing. But you can't see the elicenser (Brand new dongle purchased yesterday)

I Then pull my elicenser from the hub and replug. Pic 2 shows that it is now recognised.
Mmm.. This happens with both elicensers I have

Here is my elicenser version.

eLC Version:, eLCC Version:, POS Version:, ACC Version:, NOS Version: n/a

Title: Re: intermittent elicenser
Post by: bobk on October 04, 2012, 07:55:09 pm
I had a similar problem back in 2010 and again yesterday.

The solution provided by Arturia (after they initially tried to blame a defective USB dongle, USB hub, or computer) involved uninstalling ELCC, running three Terminal commands (which they said could possibly do serious damage to the computer if entered incorrectly), reinstalling ELCC, and running another Terminal command.

This time, ELCC was throwing errors when scanning V-Collection 3 after I installed the new version of Digital Performer (8.0).  (I'd previously been running DP 7.24.)

After the errors, ELCC would stop seeing the USB dongle, even though the Mac saw it, and the LED was lit.

The V-Collection was already installed and fully up to date, as was ELCC, and Mac OS 10.8.2 on my Mac Pro.  Some of the V-Collection plugins DID pass inspection, but when there were about 7 remaining, the problems started.

The two errors I got were:

1.  'Application '' could not be started.  Probably the file is corrupted or incompatible, or file access permissions are set incorrectly.

Please download and install the latest version of the eLicenser Control Software from....'

I'd click OK to abort, and then DP would try to verify another Arturia plugin.

After a while, I'd get:

2. 'Application 'Unknown Application' has caused the following error:

An unknown interapplication communication error occurred.  In case the problem persists, please close all applications and restart your computer.'

At this point, if I launched ELCC, it would no longer see the USB dongle.

I tried the lengthy procedure from 2010, and it worked - kind of.

I had to restart the computer (which was not in the initial procedure from Arturia).  After this, DP then successfully scanned the six V-Collection plugins which had been previously skipped, but CS80V2 still gave an error.  And again, I launched ELCC and it did not see the dongle.

I restarted the computer again, and then launched DP8.  This time, CS80V2 did pass the inspection.

In my experience, the Steinberg e-Licenser has been a real pain.   It's very buggy, and as a result I've lost many hours troubleshooting.  I wish Arturia would switch to another copy protection system, like Spectrasonics, Nomad Factory, Overloud, Toontrack, and others, who allow two disk authorizations (e.g., laptop and desktop) and avoid the USB dongle completely.

It's absurd to have to enter commands in Terminal just to use a piece of consumer software.
Title: Re: intermittent elicenser
Post by: stuart on October 04, 2012, 08:13:36 pm

thanks for the reply. I thought I was alone in having the same issues. I've since diagnosed it further and I can say it's all down to power. The e-licenser is so so power hungry that it just needs about 2 x the amount that an ilock or a reason dongle would use.

When I would insert the e-licenser it would power up, then i guess the hub would regulate itself, it was then that it would go offline.

There's nothing in the e-licenser documentation about power draw which i find really not very honest at all.

I currently have a 7 port USB hub which due to my e-licenser being so power crazed, I can't add a 7th device for fear of it going off line. I'm forced to connect and dis-connect my reason dongle when i'm not using it.

That's my workaround, and so far it's been solid 

Thanks, Stuart
Title: Re: intermittent elicenser
Post by: bobk on October 04, 2012, 11:52:46 pm
I'm not convinced it's a power issue.  Why?

Well, when opened Apple System Profiler, went to 'USB', and selected the eLicenser in the 'Device Tree' (top pane), the info in the bottom pane included the following re:  current requirements:

Current Available (mA):   500
Current Required (mA):   18

I wondered if maybe the dongle required more power when a plugin was being examined, so I launched DP 8 and had it re-examine one of the Arturia plugins (which had previously passed) and then checked to see if the 'Current Required' number changed.  It hadn't.  Maybe the Profile doesn't actively update, but I rather doubt the current requirement would change.

So the Syncrosoft dongle is drawing very little current.

If I recall correctly, AC-powered USB hubs can deliver the full USB spec of 500 mA current to each port, while bus-powered hubs supply a TOTAL of 500 mA, distributed among all the ports.

So if your hub is bus powered, and the other attached USB devices draw over 482 mA of current, then I'm guessing that would mean there's not enough current for the dongle.

(My hub is AC powered, and the user guide says it supplies the full 500 mA per port.)
Title: Re: intermittent elicenser
Post by: stuart on October 05, 2012, 12:41:12 am

I'm sure there's something else, but it must be some kind of power issue. Since removing one of my other dongles i've not had the issue, and this bugged me over replacing two powered hubs, both had that same issue.
I bought another e-licenser and it did exactly the same thing out of the box on both powered hubs. Since I removed one of my other dongles, i've had no issues and I've tested it on both hubs.

I would normally notice it more when launching my studio system, so it can't be anything to do with plug in activity and if i then plugged it directly into my mac, it would power up right away.

I read something on a Steinberg forum that the e-licenser dongle wasn't compatible if using a hub, powered or not. I then starting to move USB devices around and noticed that by leaving a spare port, it wouldn't give me issue 

It's not the nicest piece of software to use, but ive used two known good hubs and i know i have two know good e-licensers, both hubs report the same errors until i remove the last device in the chain.

I've not put a meter on it at all, i can only tell you what i have found from my testing :)

Title: Re: intermittent elicenser
Post by: bobk on October 05, 2012, 01:21:01 am
So you need to leave one of the ports empty for the dongle to work?  Very strange.

Way too many times, from different companies and for different USB devices, I've heard 'you need to plug it directly into the computer', as if their product were a rare exception.

That's ridiculous.  What about owners of laptops and iMacs?  They'd quickly run out of ports if they had to plug in more than two or three devices directly.

One of the main purposes of the USB protocol is to be able to connect multiple devices to a computer through a hub.  IMO, it's up the the device manufacturers to make that work, and many of them do a terrible job, including Syncrosoft and now Steinberg.

In any case, thanks for the info, and glad you got it figured out.

Title: Re: intermittent elicenser
Post by: joshcooper on November 23, 2012, 06:06:09 pm
Hell everyone, I am new here and just saying hello, thanks for having me and great stuff here!!! I own a florida seo ( company if anyone needs help. local seo services (