Arturia Forums

Controllers => KeyLab Essential => KeyLab Essential - Technical Issues => Topic started by: pc131 on November 28, 2021, 03:20:30 pm

Title: [SOLVED] Keylab 49 Essential encoder knob jumping values fix [SOLVED]
Post by: pc131 on November 28, 2021, 03:20:30 pm
Hi,

I bought cheap used Keylab 49 Essential, but after few days I noticed that first encoder (Cutoff/Pan 1) had random jumps instead of linear values (sometimes second knob also did random jumps, but much less). I started searching for the solution, I downloaded newest firmware, it didn't help.

I removed the knob plastic head and I sprayed with WD40 onto potentiometer shaft and I was turning left and right, so WD40 goes down into potentiometer. It helped, but hasn't removed all the jumps.

So I used another fluid to get the job done.

But I decided this time to do it more "properly".

I unscrewed bottom cover: (3 screws pointed with pink arrow are longer than rest)
(https://i.ibb.co/02Zm7nK/IMG-20211128-142951.jpg)

And I lifted the cover and moved it as red arrows show (lifting cover and moving towards you is blocked by keys/keyboard).

Then as you lift the bottom cover upwards (the part that is closer to you) you will see that there are 2 ribbons holding bottom and upper parts of keyboard.
Gently pull them out.

(https://i.ibb.co/cvvdPVq/IMG-20211008-184101.jpg)
(https://i.ibb.co/TTTnXRG/IMG-20211128-135740.jpg)

Put aside the part with keys and these two black ribbons.

Then tak the upper part and remove plastic heads of encoders and faders (pull the with fingers):

(https://i.ibb.co/jz7xXRd/IMG-20211008-184233.jpg)

Flip this upper part upside down and unscrew the board, which keeps the encoders and faders.
While lifting this board, be careful because the ribbon (marked in blue) holding this board to the board on the right is glued. This ribbon cannot be unplugged.

(https://i.ibb.co/nckK02J/IMG-20211008-184304.jpg)

There we have our potentiometers and the first form the left is encoder Cutoff / Pan 1 which had jumping values when turning.
(https://i.ibb.co/h9cttBh/IMG-20211008-184433.jpg)

I used small amounts of IPA (Isopropyl alcohol) onto the shafts, so it soaked down the potentiometer. And I was turning the shafts afterward.

And now THERE IS NO JUMPING over values of the encoder ------> https://www.youtube.com/watch?v=NFSIW788zSU

The knob turns now with less resistance than others, but works as intented. Probably this could have been done without unscrewing the whole thing, but I wanted to do it this way.

Hopefully this can help someone to fix their Keylab 49 Essential (and others with similar problem)



Title: Re: [SOLVED] Keylab 49 Essential encode knob jumping values fix [SOLVED]
Post by: MajorFubar on November 29, 2021, 02:28:24 pm
Great useful post, glad you fixed the issues.
Title: Re: [SOLVED] Keylab 49 Essential encoder knob jumping values fix [SOLVED]
Post by: echenao on March 24, 2022, 05:59:16 pm
Thanks for sharing!
I'm facing the same issue, I think the MIDI controller has an factory issue in some batch.