January 27, 2023, 03:15:40 pm
Welcome, Guest. Please login or register.
Did you miss your activation email

Arturia Forums

Post reply

Warning - while you were reading a new reply has been posted. You may wish to review your post.
Message icon:

Type the letters shown in the picture
Listen to the letters / Request another image

Type the letters shown in the picture:
Write arturia backwards, without uppercase:

shortcuts: hit alt+s to submit/post or alt+p to preview

Topic Summary

Posted by: Brian Hayes
« on: December 12, 2022, 03:11:52 am »

Okay - i know it's been a while, but I just bought a keystep pro and had this same issue, which I was able to resolve. Here are the steps I took.

1. I went to https://www.arturia.com/support/downloads&manuals and redownloaded MCC for my Windows PC running Windows 11 (https://downloads.arturia.net/extra/mcc/MIDI_Control_Center_1_14_1_2.pkg).
2. I installed the new version of MCC with my Keystep Pro plugged in and on.
3. After installing I also selected an option to update USB settings
4. This time when I opened MCC, it auto asked me to update the device to 2.0.1, which I did successfully (verified in settings on device).
5. MCC then showed "burn successful" and told me to reboot the KSP. I did and then hit okay and it sync'd with it now showing the firmware version accurately.

Hope this helps!
Posted by: MajorFubar
« on: August 11, 2021, 10:28:48 am »

For some stupid reason there are versions that do not transmit data
That's because they are just charging cables for devices which use microUSB, like mobile phones and bluetooth headsets. They are usually advertised as exactly that: charging cables, but people don't realise there's a difference.
Posted by: DJ BIRDLAW
« on: August 11, 2021, 04:08:17 am »

I had the exact same issue: it's probably the cable. For some stupid reason there are versions that do not transmit data, and you cannot tell the difference by looking at them.
Posted by: MajorFubar
« on: August 29, 2019, 01:14:53 pm »

Nice one, glad you got it sorted.
Posted by: jayrope
« on: August 28, 2019, 10:47:20 pm »

Posted by: jayrope
« on: August 28, 2019, 10:26:00 pm »

MajorFubar, good suggestion, probably solves 95% of all of those cases already.
But no, i am using the original UBS cable, and as well my Keystep mounted meanwhile.
A glitch of Audio MIDI setup i would guess.
However, i cannot update to the newest firmware, even if i follow the advice in https://www.arturia.com/faq/installation/firmware-reset-and-detection-of-a-midi-device
The recommended procedure there doesn't work with me.
Posted by: MajorFubar
« on: August 28, 2019, 01:23:11 pm »

Sounds to me like you're using a cable that's only got the power lines connected not the data lines, consequently the Keystep powers up but as far as the computer's concerned it doesn't exist. Make sure you're using the supplied USB cable (which you may be doing, but worth checking)
Posted by: megamarkd
« on: August 28, 2019, 03:17:46 am »

Do you know someone with a PC who will let you install MCC onto it and attempt update your KeyStep?  When installing MCC onto a Windows PC, it installs the Arturia MIDI driver as it goes.  You get to see it happening so know it has installed the driver correctly.  I've noticed that there seems to be issues with some OSX machines when doing a search to find a solution in the past, I can't pinpoint the common factor though.

I have also attemted to connectit to my Windows 10 PC with midi-ox installed to detect any midi device. again the keystep does not show up.

If you haven't installed the Arturia MIDI driver, I don't know if MIDI Ox will detect the device.  Make sure you have an updated version of Win10 (which is actually pretty hard to not have considering how MS are all but forcing the updates on Win10) and the most current version of MCC.
Only issue I've ever experienced with my KeyStep and BSP not connecting to a Windows PC was when using a USB port on my desktop that has poor connections with any USB device it is given, so I use a port that I know has a good strong data transfer rate and can provide enough power at the same time.  Perhaps test the port by doing a simple file transfer to a USB harddrive or a phone first to ensure it capable.
Posted by: damnedcat777
« on: August 28, 2019, 02:25:46 am »

Same problem here.  Using TWO MacBook pro's from the SAME year with the SAME abilities...  This upgrade is uninstallable.  IT WILL NOT INSTALL!!!  IT WILL NOT!!!!

This is some def BS.  Seeing a video of everything that it's suppose to do, and NOT even being able to install the upgrade????

Beyond frustrating.

W. T. F.???????
Posted by: jayrope
« on: August 25, 2019, 06:05:48 pm »

Same issue here. Any other USB keyboard i have automatically connects to my Mac without even having to scan for it.
The Keystep turns on, so USB power does work. It plays fine standalone, using it mostly to control CV.
(Thanx for that feature!)
I'm on OSX 10.9. and i don't want/need to upgrade otherwise;)
I am using Midi Control Center 1.7.1. (the last version certified from 10.8.)
Any help?

I'll otherwise have to return the unit to Thomann i guess.
Posted by: gossamerjohn
« on: July 22, 2019, 10:49:11 pm »

Did you ever get this resolved?
Posted by: bitbin
« on: March 13, 2019, 05:17:00 pm »

Same issue here.
Posted by: chipsngravy
« on: February 18, 2019, 04:17:50 pm »

I have a brand newan Arturia Keystep.
I am connecting it to my iMac via the cable supplied, straight into the usb on the iMac(not a hub).
The key step is lighting up so is receiving power, however, It is not been seen by the Arturia Midi control centre, the software says there is no device connected.
I am unable to do firmware upgrade as the Keystep is simple not seen as connected.
It does not show up in my Logic pro x (Version 10.4.1. I have tried all the steps on the Arturia troubleshooting page, deleting devices in the Audio Midi setup etc..
I am beginning to come to the conclusion that the keyboard it self is malfunctioning?
My operating system is macOS Mojave 10.14.2,
I have also attemted to connectit to my Windows 10 PC with midi-ox installed to detect any midi device. again the keystep does not show up.

Has anyone had the same problem and fixed it or am I missing something in the setup of the keylab.
All help appreciated.
Thanks folks
Carbonate design by Bloc
SMF 2.0.17 | SMF © 2019, Simple Machines