January 28, 2023, 11:09:27 am
Welcome, Guest. Please login or register.
Did you miss your activation email
News:

Arturia Forums




Post reply

Warning: this topic has not been posted in for at least 120 days.
Unless you're sure you want to reply, please consider starting a new topic.
Name:
Email:
Subject:
Message icon:

Verification:
Type the letters shown in the picture
Listen to the letters / Request another image

Type the letters shown in the picture:
Write arturia backwards, without uppercase:

shortcuts: hit alt+s to submit/post or alt+p to preview


Topic Summary

Posted by: aerdman
« on: June 07, 2022, 10:51:13 am »

Right, indeed it is not connected to any external clock and runs in master mode.
Already contacted the seller. Thanks for the response.
Posted by: Koshdukai
« on: June 07, 2022, 10:33:01 am »

If you don't have it receiving Clock externally, which could cause that by design (though the clock source could the culprit) then your unit is clearly faulty because that's not supposed to happen when in Standalone (i.e. when not slaved to another clock).

If unrelated to Clock, then it could be a faulty Start/Stop button.

I would contact the seller for a replacement.
Posted by: aerdman
« on: June 07, 2022, 10:25:59 am »

Hi!
I just purchased Arturia Beatstep and it works terribly. The sequencer starts and stops randomly.
I tried updating firmware (although it was already at the freshest version 1.2.0.3), but if anything, it only made things worse.
Here it is captured on video: https://youtu.be/clpNDZnlTWk
The problem is the same if connected to a PC or just to a power adapter.
I found a few mentions over the internet of the same problem, but no solutions were described.
Do I just get a replacement/refund or is there a potential solution to this?
Carbonate design by Bloc
SMF 2.0.17 | SMF © 2019, Simple Machines