February 06, 2023, 06:18:16 am
Welcome, Guest. Please login or register.
Did you miss your activation email

Arturia Forums

Post reply

Warning: this topic has not been posted in for at least 120 days.
Unless you're sure you want to reply, please consider starting a new topic.
Message icon:

Type the letters shown in the picture
Listen to the letters / Request another image

Type the letters shown in the picture:
Write arturia backwards, without uppercase:

shortcuts: hit alt+s to submit/post or alt+p to preview

Topic Summary

Posted by: damnedcat777
« on: October 11, 2019, 03:37:13 pm »

TerryM:  I am sure this will help me.  If the synch button does not and is not suppose to 'appear' on the midi control center for MF, I think I'm good.  But I will try the other stuff you listed to make sure the MF is being 'seen' by my MacBook.  I was able to upgrade the firmware on the MF and my Keystep with a Windows 10 laptop.  That won't mess these up (Keystep & MF) if I use them with my MacBook... will it? Thats the only question I could use answered this time around (please).

I figured the firmware is actually INSIDE of the Keystep and Microfreak, right?  So it doesn't matter WHAT computer I have them hooked up too.  Right.  Right? 

Christ Im shite on these here 'pewter thingeys.

BTW, I fucking LOVE LOVE LOVE the MF!!!!!  You guys just SO fucking nailed it on this!  Working at Arturia must be the greatest gig in the world!!

Thanks again, will try all your help out on my MacBook in a few hours, when I get some time.  You guys are DA BOMB!!!
Posted by: Terrym
« on: October 10, 2019, 09:38:49 pm »

Hi, I know sometimes its seems that macs do not like arturia products. but first we need to see where the issue is.
I still use a 2012 MacBook pro on the latest osx .
So first lets see if you MF is showing up in the system at all. Sorry if you know this already but worth a try.
So plug in a usb cable to the mac and mf and turn the unit on. Go to the apple sign and open about this mac.
click on system report, click on the side panel usb.in the usb tree do you see Microfreak  yes? or no?
If no the mac cannot see it due to hardware or wrong cable please try the other usb port and start  from the top again.
It should show unless there is a hardware failure.
if you do see it go to audio midi setup.and look for the arturia driver. if you cannot see it is there a driver named general midi device  ids so delete it  but before this turn off the micro freak.
and then turn on MF . does the drive reappear it should be highlighted in white if its talking to the MF.  is the name correct?
Next shut down your comp and the restart go to audio midi setup. is it renamed and highlighted? correct name.
if its good open the mcc ( latest updated version).  is it connecting to the mcc .

The sync button is greyed out and is not used by Microfreak.

hope this helps

Posted by: damnedcat777
« on: October 10, 2019, 04:42:03 pm »

OK, I just tried to use a Windows lap top, and after downloading everything on the MIDI control center, I STILL do not see a "synch" button after connecting the microfreak. BUT: I WAS able to FINALLY update the firmware on my Keystep (OH, JOY JOY JOY! It only took 8 weeks!!!), but still no "synch" button on the microfreak's midi control cneter page option. I Am beginning to think there ISN'T a "synch" button, is there?

The Windows lap top "sees" the microfreak, so at least I have that.  I could still use help getting my Apple macbook pro to see it.  Any help?

Someone from Arturia, maybe?
Posted by: damnedcat777
« on: October 10, 2019, 03:41:36 pm »

I am having the same problem I have with my Keystep, only worse.  The key step won't upgrade firmware.  The microfreak doesn't show up on my MacBook anywhere, at all.  Not the audio midi setup, not anywhere.  I have tried 17 USB cables, still: no luck.  What gives?  Is it supposed to show up, or is it totally a separate instrument, like hooking up a Les Paul?  I don't get it.  How can something so new (I took it out of the box yesterday) be so useless via a MacBook?  Is there a fix to this?  How do I get my computer to realize there is a brand new microfreak connected to it?

Plz, someone: help.  I have all but thrown my Keystep away: there is just NO WAY the Keystep's firmware can be upgraded on a 2011 MacBook Pro. It just can't.  The end. Which, considering the 9v input quit working 9 months ago, I'm guessing it just broke. It wasn't designed to last longer than 10 or 12 uses.  OK.  I get that. It was under $100. It's dead.

But this microfreak is BRAND SPANKING NEW.  AND it was $300!  How can this NOT be recognized by a MacBook Pro running a cutting edge OS?

Makes no sense.

Can anyone help here?  This seems to be a MUCH LARGER time suck than anything else.

Solutions?  Plz? I don't wanna walk away from Arturia after spending so much cash (I own 10 of their hardware and 25 of their software, EASY), but this thing is about as useful on a computer as Hellen Keller.
Carbonate design by Bloc
SMF 2.0.17 | SMF © 2019, Simple Machines