February 06, 2023, 11:35:19 pm
Welcome, Guest. Please login or register.
Did you miss your activation email
News:

Arturia Forums




Post reply

Warning: this topic has not been posted in for at least 120 days.
Unless you're sure you want to reply, please consider starting a new topic.
Name:
Email:
Subject:
Message icon:

Verification:
Type the letters shown in the picture
Listen to the letters / Request another image

Type the letters shown in the picture:
Write « arturia » backwards, without uppercase:

shortcuts: hit alt+s to submit/post or alt+p to preview


Topic Summary

Posted by: MajorFubar
« on: December 24, 2021, 09:12:26 am »

Useful post thank you
Posted by: Scryptitious
« on: December 24, 2021, 06:11:28 am »

Hi everyone,

When I press play in Ableton Live this appearing to be sending an start/stop message to the Keystep so if I play the Keystep it sound arpeggiated in order to play like a normal piano, I have to press stop in the Keystep. I Have to do this everytime I press play in Ableton Live in order to play like with a normal piano.(no arp or sequence behaviour)

The "midi control center" doesn't seem to have an option for disabling the Keystep for reciebing this "start/stop message". I can't find this in ableton neither.

I'm adding a post to this ancient thread because it's the first one that comes up in the google search, "How do I disable the Keystep 37's sequencer?" This is for anyone who arrives at this thread via a search engine and just wants an answer to that question.

The OP wanted to play their Keystep "like a normal piano" to record a part in Ableton. That means they wanted to disable the sequencer, play a part and then possibly switch the sequencer on again to record a sequenced part.

The solution is simple and works with any DAW.

Reach behind your Keystep and, with your thumbnail, move the two dip switches to the lowest position. Congratulations. You've just switched the Clock sync from USB to internal. You will still be able to send USB/MIDI messages to your DAW by playing or adjusting controllers. Like an old school MIDI/USB keyboard, your Keystep just won't receive the clock.

When you do want your DAW to record a sequenced part, flip your Keystep, note the illustration showing the dip switch position for USB and adjust the switches accordingly. Now you can record your sequence.

Yes, it would have been nice to enable and disable clock sync from the front panel of your Keystep. But since you're working with a DAW and not switching clock sources live, changing the dip switch positions shouldn't derail your workflow.

 
Posted by: osclab
« on: November 24, 2020, 06:41:08 pm »

Just got a Keystep37 and had the same question... Now its in the config as "Armed".
But why would it not be that when Stop is selected then it's not armed, and when Play/Pause is flashing the it is armed?!
Will email Arturia about it .. this forum captcha is horrible.
-------------
New “Armed” setting
This new option changes the way sequencer and arpeggiator of KeyStep behaves when it receives clock signals. This can be toggled “on” and “off” in the MIDI Control Center.
ON: the user arms the sequencer by pressing Play. When armed, an incoming clock signal will start the sequencer. Otherwise, KeyStep will stay in STOP mode. In this mode, the incoming clock will be transmitted even when the internal sequencer isn't playing.
OFF: the sequencer will automatically play and send clocks when an external clock signal is received on the selected clock source.
Posted by: Ralvek
« on: July 19, 2020, 08:38:24 pm »

Noting I got this to work for me, Im just trying to control and record midi from a SH-101 and V-synth. here is what I did:

First Keystep is in ARP mode

Open Midi Control Center
Go to Device Settings
Under Sequence Settings change the following:
-Sync Clock Start to "On Gate Start"

Under Transport Settings, turn transport mode off

So far this has allowed the keystep to work for my usecase. I can playback my daw, the clock is still received, but it is not triggering the keystep to play its internal sequence/arp.
Posted by: raw
« on: February 22, 2020, 08:04:52 am »

2020. just bought this. had no idea the arp would keep running. *sigh

Can't they patch this in?
Posted by: landrvr1
« on: December 17, 2019, 09:36:35 pm »

Holding down the Shift button when hitting the play button in Ableton works well.  Another method: On the KeyStep, hold down Shift and pick another MIDI channel based on the blue numbers above the keys on the left - then hit the Play button in Ableton.  When you are ready, hold down Shift again and select the key with the proper MIDI channel you've already set on the track in Ableton (which means you can't leave the track MIDI as 'all ins'.  Similar to the first method, since the clock signal is already being sent to the KeyStep it doesn't matter when you select your proper MIDI channel - everything will automagically be in time to the Ableton sync.  For seamless play, you'll just want to tap the MIDI channel key at the top of your bar...
Posted by: Mattog
« on: May 31, 2019, 07:25:59 pm »

Hold down the shift key on the Keystep when starting the controlling device. Not ideal but it works when I slave from my MPC Live.
Posted by: megamarkd
« on: October 29, 2018, 02:27:44 am »

Hi, +1 on this request if possible please.

Brainstorming here, anyone know if there's a way to record a blank SEQ so that even when I hit play on the Keystep it plays all "rests" or nothing at all or could I put in ARP mode and have some sort of blank or stopped setting somewhere? I just bought the keystep so I'm pretty new.

I'm basically using the Keystep as a small midi controller connected via midi to a Ju-06 boutique, and it's USB to DAW (Logic) to try and use the Keysteps play/stop buttons to control Logic's transport (off stage). Could I not just use the Keystep as a compact midi controller (sending MIDI to outboard synth) with transport control being used to start\stop a DAW at the same time without starting a seq\arp?

Any ideas are greatly appreciated!

Hit record, enter one rest, press stop.  You now have a one-step blank sequence.
Posted by: fhooper
« on: October 26, 2018, 07:09:07 am »

Hi, +1 on this request if possible please.

Brainstorming here, anyone know if there's a way to record a blank SEQ so that even when I hit play on the Keystep it plays all "rests" or nothing at all or could I put in ARP mode and have some sort of blank or stopped setting somewhere? I just bought the keystep so I'm pretty new.

I'm basically using the Keystep as a small midi controller connected via midi to a Ju-06 boutique, and it's USB to DAW (Logic) to try and use the Keysteps play/stop buttons to control Logic's transport (off stage). Could I not just use the Keystep as a compact midi controller (sending MIDI to outboard synth) with transport control being used to start\stop a DAW at the same time without starting a seq\arp?

Any ideas are greatly appreciated! 
Posted by: mbm
« on: October 18, 2018, 11:41:16 pm »

Echo above. Keyboard is really anoying to use without option to disable ARP/SEQ.

Shift+midich1 key + midich3 key: Disable. Shift+midich1 + midich5 key: Enable. Cant be difficult to upgraede in firmware.

It is an awesome keyboard - a modern version of the classic simple Roland PC180e.

Please  ;D
Posted by: Randolfenstein
« on: September 27, 2018, 04:51:17 pm »

Ok, so using my DAW, I have a MIDI clock going to a hardware MIDI output, to a 5 way splitter, and each split goes to a different Controller/Synth daisy chain. For example, from the splitter, I have a daisy chain of Octatrack to RYTM to Machinedrum. This daisy chain never fails. Elektron have this down. Arturia, on the other chain, do not yet have this area fully developed.

On another split, I have a daisy chain of the KEYSTEP to Beatstep Pro to OP-1. The Beatstep acts as an external sequencer (soon to be replaced by a Squarp Pyramid), live-capturing whatever I play on the KEYSTEP, and pumping it into the OP-1, in full looping glory. I enable and disable recording on the Beatstep Pro and control patterns to decide what gets looped, and what simply passed straight through to the OP-1.

Press play on DAW, and the elektrons do all their stuff perfectly, and and the KEYSTEP starts with the Beatstep Pro with the OP-1, all wonderfully. You know what I’m about to say. Anything I play on the KEYSTEP will be processed by the arpeggiator or sequencer. I want the OP-1 to be able to play ARPREGGIOS AND tasteful musical ideas, on and off. The goal is to be able to switch between ARPEGGIOS and natural playing, and back to ARPEGGIOS, when ever I see musically best. Currently, the chain starts just fine if all I want is arpeggios, and to switch to natural playing, (we all know) I hit the stop button on the KEYSTEP, and yes, I can then play naturally. But that stop message is forwarded down the MIDI chain to the Beatstep and the OP-1.

Guys at Arturia, I don’t imagine it to be too hard to find a way to work around this hindrance. How about a shift command that disengages the ARP/SEQ engine alone, leaving the sync flow untouched.

Let’s assume this issue isn’t fixed. I can solve the sync problem with the splitter, doing parallel sync to the OP-1 through my OP-Lab, already in use as a MIDI host, to the OP-1. I press play on the DAW, and then eventually I press stop on the KEYSTEP, to move to natural playing, but when the time comes to nails some dreamy arpeggios perfectly to the Elektron gear, nope, sorry folks. The KEYSTEP manual play will not resume locked to the sync. Couldn’t we (arturia techs) get the play button quantized to the incoming sync signal, since it is hardwired with the rear switches to be sync’d to the incoming clock? Only a robot could hit that play button perfectly enough to get the arps back into perfect sync.
Posted by: OralB
« on: March 19, 2018, 02:56:50 am »

has this been fixed yet?  ???

i just bought a keystep presuming this problem would have been fixed by now :(

arturia need to add an option to the software "receive clock without starting arp/sequencer" to the software.

arturia please add this -- this is very frustrating :(
Posted by: kfunk
« on: February 25, 2017, 03:46:18 am »

I found a solution with this in Ableton in the preferences in the link MIDI section in the Midi ports area,make sure the Sync is set to off for the Output row for the KeyStep. Once I turned this off the keystep starts as expected when pressing the play button. I hope this works for others.
Posted by: megamarkd
« on: February 13, 2017, 06:03:18 am »

ChitownTim, you must be sending play/stop messages from another source onto the Keystep as it won't start if it doesn't receive a start message.  I have set up my MIDI path so that the Keystep is constantly receiving (and sending) MIDI timing.  It starts when I press play on another sequencer or if I press play on it.  If I don't want it to keep starting when I press play on a sequencer up stream from it, I need to filter realtime messages from the MIDI signal, which would mean no MIDI sync for the Keystep or anything between it and the filtering device.

Oh yeah, my MV8000 has the capacity to start, pause, continue, stop via MMC, but you know what?  It doesn't do it.  Not a single thing I own that can run on MMC will work properly using only MMC.  Not the QY-700, not the MV8000 and not the E-MU e5000 ultra.  When I first got the E-MU, a friend who was running a DAW mentioned that MMC is really for controlling things other than instruments as it doesn't send synchronisation data.  It's a waste of bandwidth to use send it to anything other than a multitrack, he reckoned.
Posted by: ChitownTim
« on: February 08, 2017, 06:53:15 pm »

I don't want to disable MIDI clock.  We all need the clock signal to keep the arpeggiator and sequencer in the Keystep in sync with the source (a DAW or an MPC in my case).  But Arturia (maybe as an unintentional oversight) designed the Keystep to start the arpeggiator/sequencer upon receipt of MIDI clock.

It would be nice if Arturia programmed the Keystep's arpeggiator to actually start with MMC instead of MIDI clock. 
Carbonate design by Bloc
SMF 2.0.17 | SMF © 2019, Simple Machines