December 23, 2014, 02:44:01 am
Welcome, Guest. Please login or register.
Did you miss your activation email
News: Arturia's webmaster is glad to offer you these brand new forums ! Have fun using it and feel free to email any encountered problem at webmaster@arturia.com.

Arturia Forums



Author Topic: Has anyone got FX pad working when Spark is midi controller?  (Read 537 times)

audiosculpture12

  • Apprentice
  • *
  • Posts: 26
  • Karma: 0
I've got a complicated problem that Kevin is hopefully looking into, but i'm just posting here in case anyone has experienced it.

I am trying to setup the spark as a midi controller in Logic 9. Not using the Spark plugin, but to control other plugins.
Using the spark midi control centre, I am able to specify what messages are transmitted. However, when using both the FX pad, pattern buttons, and possibly the step buttons too (i haven't checked that far) there is a problem.

As well as transmitting my selected message, it also sends out F no3 maj7 chord when i hit the fx pad, and for instance on pattern 1-16, sends out F1 with varying velocity according to which is pressed. This is not always visible in the environment  "input view", but IS visible in Logic's transport, and does affect the plugin, and trying to assign the CC to the plugin. If i change the message to nothing, the problem disappears. But of course i need a message to be outputted!
Private ports are disabled by sending to a null instrument as per the video and manual.
The FX pad was a key feature that swung the Spark over the Maschine, so i really hope this can be sorted and it's just a weird quirk!

I'd be very grateful for any assistance, I can't integrate spark into my workflow until this is sorted.  :)


audiosculpture12

  • Apprentice
  • *
  • Posts: 26
  • Karma: 0
Re: Has anyone got FX pad working when Spark is midi controller?
« Reply #1 on: June 22, 2012, 11:41:00 am »
OK well i am almost certainly shooting myself in the foot a bit here, but if you get the controller set up how you like in the spark midi controller setup program, then disconnect the usb cable...

...and reconnect with old school midi...it seems to work.

 :o 8) ::) :-*
I really hope Arturia manage to get this working properly with logic as disconnecting and reconnecting the usb isn't exactly the smoothest solution, and of course you now need a 9vDC adaptor to power it.

But it does save me from the evils of NI...



 

Carbonate design by Bloc
SMF 2.0.8 | SMF © 2014, Simple Machines