November 24, 2014, 10:42:31 pm
Welcome, Guest. Please login or register.
Did you miss your activation email
News: Arturia's webmaster is glad to offer you these brand new forums ! Have fun using it and feel free to email any encountered problem at webmaster@arturia.com.

Arturia Forums



Author Topic: AE 25 THE PLAYER is sending only on MIDI-Channel-1!?!?  (Read 1456 times)

Manuel

  • Sr. Member
  • ****
  • Posts: 331
  • Karma: 1
  • GTHC-Entertainment
    • MySpace
AE 25 THE PLAYER is sending only on MIDI-Channel-1!?!?
« on: February 10, 2012, 11:51:41 am »
Hi,

I know how to used THE MCC but its not working! I want to change the MIDI-Channel for my Player 25-Key Controller to CH-2. But the Keyboard doesn't recorgnize the changes. I save the changes and when I close and reopen the MCC the Global-MIDI-Channel is set to CH-2,
but the Contoller is still sending on MIDI-Channel 1.   ???

I use Ableton Live 8 and three MIDI-Controller

1. Numark DJ2GO
2. Arturia AE-25 The Player
3. Arturia AE-49 The Laboratory

For Device 1. There is no application to change any values.

Device 3. Is working fine and I can change Channels using The Laboratory MCC or the Setup-Function on the controller.

Device 2. should be able to change the Global-MIDI-Channel by using the MCC but it's not working!

This causes some problems with my Setup!

Anybody experienced the same problem?

Koshdukai

  • Beta-testers
  • Sr. Member
  • *
  • Posts: 439
  • Karma: 19
Re: AE 25 THE PLAYER sends only on MIDI-Channel-1 !?!?
« Reply #1 on: February 10, 2012, 02:24:51 pm »
I'm not near my AF controller, but if I'm not mistaken, the MCC has a lot of issues with the SysEx it's sending to the controller. I remember checking the MIDI stream and I think the MIDI Channel change SysEx was missing, among others, if I'm not mistaken.

Basically, it's a bug in AF's MMC that needs fixing.

Manuel

  • Sr. Member
  • ****
  • Posts: 331
  • Karma: 1
  • GTHC-Entertainment
    • MySpace
Re: AE 25 THE PLAYER is sending only on MIDI-Channel-1!?!?
« Reply #2 on: February 10, 2012, 10:12:47 pm »
Basically, it's a bug ...

Thankx for the info!

So I think we have to wait till they fix it.?! ... again! With The Laboratory MCC it was worse but it's still not completely fixed. (Category- and Preset-Controller are still not working as they should)

In my case the problem is that the C4-Key on my The Player is triggering the same function as the Cue-Button (Deck-B) on my DJ2GO. And others ???

I could set "Global" off for The Player (In Live's Prefs.), so that I just controll "Track in" but  if I use other VST-Plugins like Tone2 Firebird, Nexus2 etc., I have to assign the controller manually and there for "Global" has to be on. Otherwise I can only play notes and the encoder-knobs are not assignable to any of the plugins functions.
 :o ??? ::) :'(

I really love to play the keyboards but the MCC of the whole ANALOG EXPERIENCE series just sucks!

>:(UPDATE THE MCC FOR THE AE-KEYBOARD-CONTROLLERS!!!>:(

Manuel

  • Sr. Member
  • ****
  • Posts: 331
  • Karma: 1
  • GTHC-Entertainment
    • MySpace
The Solution was realy easy!
« Reply #3 on: February 13, 2012, 02:16:44 pm »
After I recieved this message from ARTURIA I couldn't wait to try it this way:


Hi Manuel,
 
On the MIDI Control Center ,would you please select 'Default values' then reselect the Channel you desire to use (2 in this case) ,then click on 'send to keyboard' . Reboot your keyboard and have a test .
...
Best Regards,
 
Amine.
--
Arturia Technical Support
support@arturia.com
---------------------------------------------------------------------------
http://www.arturia.com




I just had to open the MIDI Controlle Center, load the default values and change the MIDI-Channel to "2". (I did this many times before!), but after I closed the MCC and turned off The Player, I  rebooted my system, turned on The Player and The Laboratory and it worked out! (DJ2GO was connected with my system during the whole prozess)

First I tried to reboot only The Player but The Player was then device 1. (Maybe the DJ2GO controller was not connected to the system at this time) However!

Finally I can use all three controllers.  :D

.... Thanks for the support ! ....


Koshdukai

  • Beta-testers
  • Sr. Member
  • *
  • Posts: 439
  • Karma: 19
Re: AE 25 THE PLAYER sends only on MIDI-Channel-1 !?!?
« Reply #4 on: February 13, 2012, 02:51:03 pm »
hmmm... that's weird. Oh wait, you own THE PLAYER!!!

I described the behavior of THE FACTORY MMC, sorry!

Different tools, even though, used to achieve almost the same.

 

Carbonate design by Bloc
SMF 2.0.8 | SMF © 2014, Simple Machines