November 21, 2014, 12:13:03 am
Welcome, Guest. Please login or register.
Did you miss your activation email
News: Arturia's webmaster is glad to offer you these brand new forums ! Have fun using it and feel free to email any encountered problem at webmaster@arturia.com.

Arturia Forums



Author Topic: HORRIBLE TECHNICAL SUPPORT! NEVER USE!!!  (Read 1250 times)

mkuerschner

  • Apprentice
  • *
  • Posts: 5
  • Karma: -2
HORRIBLE TECHNICAL SUPPORT! NEVER USE!!!
« on: February 25, 2014, 09:52:41 pm »
It has now been over a year since my mini brute has been out of commission, and I have yet to see it back. I can not begin to tell you the frustration I have had with this company. I was told to send in my unit to a place in Washington where I had to pay for the shipping (even though it broke within the first 60 days of having it for no apparent reason), and I never heard a single word from this "authorized" repair shop. I tried emailing and calling them several times to see when I could expect my minibrute back, but never got any response. I then turned my search to Arturia since I was afraid I would never see my minibrute again, and after several unanswered emails I got a message saying that they needed to wait until February to send me a new unit because supplies were low. I agreed to this, but never heard anything back after that. I have been sparsely contacted over this issue and still have not received my minibrute back. They basically confirmed that I would never get the original one I had back and offered to send me a new one, but have yet to receive it or even a timeline of when I could expect it. This is the absolute worst technical support I have ever received, and I can assure you I will never purchase another product from Arturia ever again. STAY AWAY, go out and get a product that won't break right away and that a company will actually stand behind and support! I will be taking appropriate legal action.

stevism

  • Beta-testers
  • Full Member
  • *
  • Posts: 239
  • Karma: 4
Re: HORRIBLE TECHNICAL SUPPORT! NEVER USE!!!
« Reply #1 on: February 25, 2014, 10:44:59 pm »
yeah it seems like they've gotten really really bad. that's crazy that you're out what, $600 (tax+shipping+unit+etc)? totally unreal.

they very helpful to me when i had problems early on, but the amount of heartache on these forums over the past 6months - year is astounding.

curious to see how your case goes

mkuerschner

  • Apprentice
  • *
  • Posts: 5
  • Karma: -2
Re: HORRIBLE TECHNICAL SUPPORT! NEVER USE!!!
« Reply #2 on: March 02, 2014, 05:44:39 am »
Got an email mid last week saying it wouldn't ship until March now... said that was unacceptable and never heard a response AGAIN. SO FRUSTRATED.

casey.feskens@gmail.com

  • Newbie
  • *
  • Posts: 1
  • Karma: 0
Re: HORRIBLE TECHNICAL SUPPORT! NEVER USE!!!
« Reply #3 on: March 07, 2014, 05:19:30 am »
I ended up with the broken key issue after 8 months.  Contacted support.  Had a response within 24 hours, diagnosis within 2 days.  Received RMA info.  Sent my brute away and had a new one back to me in 6 weeks.  I am a happy support customer.  Sorry about your experience.

Varthdader

  • Apprentice
  • *
  • Posts: 19
  • Karma: 0
Re: HORRIBLE TECHNICAL SUPPORT! NEVER USE!!!
« Reply #4 on: March 12, 2014, 07:06:39 pm »
Great to hear that at least somebody had a resolution to this issue.

Sadly, I have had my Minibrute with a broken keybed since late August and still donīt even have an estimated ship date for the replacement I was promised.

I really hope I am not abandoned on this.

mkuerschner

  • Apprentice
  • *
  • Posts: 5
  • Karma: -2
Re: HORRIBLE TECHNICAL SUPPORT! NEVER USE!!!
« Reply #5 on: March 12, 2014, 08:57:30 pm »
Good to hear someone had a good experience. Talked to a buddy who works for Guitar Center and heard that this kind of experience seems pretty typical when dealing with Arturia. I only get sporadic responses, but I was told the new one would ship March 10th. Never heard anything after that, tried to get my tracking information this week to no avail. It's really disheartening that I only get a response back about once a month, no matter how often I try to contact them. Was really interested in getting more Arturia products when I first purchased my Minibrute, but definitely have been deterred with this experience.

Dav1d

  • Administrator
  • Hero Member
  • *****
  • Posts: 574
  • Karma: 27
Re: HORRIBLE TECHNICAL SUPPORT! NEVER USE!!!
« Reply #6 on: March 13, 2014, 02:16:30 pm »
Finally, this is an official announcement.

"We are of course aware of the issue that affected some Minibrute units in two specific production batches from 2013.
We did investigate and found the cause of the issue. (At a certain points during the production of the keybed parts, the injection of plastic into the mold was not done at constant temperature. This created a weakness in some keys.)
This concerns in fact a limited number of products even if people having issues are naturally more vocal -and have all the rights to be. Less than 4% of the keyboards within these two batches were affected. Still Arturia did replace all keybeds in their entire stock and so did their distributors as well. We are aware that some units have reached end-users this is why we extended the guarantee to three years on the MiniBrute keybeds. Of course we have put more quality controls on the production following this problem.
In any case the Special Edition comes with keybeds that have been tested right. So you should not be scared.
As a conclusion we understand the frustration of customers who trusted us and got issues with the MiniBrute. We have replaced faulty units as quickly as we could, along with our distribution partners and we will keep on doing so when needed. But it should not affect the value of a good product that is reliable and used by many musicians now."

We just received a shipment of containers in regard of the Keybeds issues.
Depending on the warranty period, we can send the new Keybeds directly from you or from our distributors:
==> http:// [url]http://www.arturia.com/evolution/en/buy/distributors.html [/ url]

For the US : us_support@arturia.com

For the rest of the world, If you have not received a reply or you're out area, please write an email to the following address:
distributors.support@arturia.com

We need this specific information:
1/ A picture showing the issue
2/ Your address and phone number
3/ For the warranty, a proof of purchase of the product.

Please note that we will do our best to provide you with keyboards in Timely Manner.
 :)
« Last Edit: March 14, 2014, 06:09:28 pm by Dav1d »

lavenir

  • Apprentice
  • *
  • Posts: 3
  • Karma: 0
Re: HORRIBLE TECHNICAL SUPPORT! NEVER USE!!!
« Reply #7 on: September 25, 2014, 05:47:01 pm »
I must say that support is HORRIBLE. The filter went out in my unit after a little bit over a year and after two months of frustrating back and forth, having me shoot multiple videos to illustrate problem etc, they finally admitted there was a hardware issue but wanted $300 plus shipping both ways for the repair. You do the math. Is a MiniBrute worth a little over $800. I seriously don't think so. I'll go buy a second SH-101 for that price. Which is over 30 years old and still working. Now their stonewalling the shop I purchased the Brute from that offers an extended warranty on their products. Nice.

In the past if I'd had to deal with Oberheim, Doepfer, Dave Smith, Pittsburgh Modular etc... with questions or whatever, they've been MORE than helpful, polite and QUICK to resolve whatever issue I've had.

NEVER buying an Arturia product again, and I'm NOT recommending their products to my students or buying them for the electronic music program I run at my university.
 
Very frustrated.

GrimeMonster212

  • Newbie
  • *
  • Posts: 1
  • Karma: 0
Re: HORRIBLE TECHNICAL SUPPORT! NEVER USE!!!
« Reply #8 on: October 27, 2014, 01:57:22 pm »
My minibrute started experiencing crazy volume and pitch modulations on its own accord (i would have a basic patch set in, LFO was not in use nor any other modulation).. this was roughly 8-9 months ago

then, the sound just completely died... no matter what I do, my minibrute is mute..

Support seemed helpful at first, but then after two weeks they just stopped replying... now, I am out $600 give or take and I have the most useless/cumbersome paperweight imaginable.. STILL no reply from Arturia after those first two weeks of "support" they provided

Arturia has lost a customer, and I will do my best to persuade anyone interested in them to look elsewhere.. unacceptable

 

Carbonate design by Bloc
SMF 2.0.8 | SMF © 2014, Simple Machines