December 22, 2014, 08:35:28 pm
Welcome, Guest. Please login or register.
Did you miss your activation email
News: Arturia's webmaster is glad to offer you these brand new forums ! Have fun using it and feel free to email any encountered problem at webmaster@arturia.com.

Arturia Forums



Author Topic: Bugs, Bugs, and more Bugs...Massive MMV2 Bug List  (Read 27356 times)

porfiry

  • Newbie
  • *
  • Posts: 2
  • Karma: -1
Re: Bugs, Bugs, and more Bugs...Massive MMV2 Bug List
« Reply #45 on: July 13, 2009, 03:15:45 pm »
a) I think you have me confused with the original poster

b) "You won't have real-time information on MMV2 bugs resolution or day-per-day new features implementation."

Super, but this thread is nearing THREE years old, and as the OP stated, the bugs he listed had already existed for years at that point. You're the first employee of the company who's shown up here in all that time, as this thread has sat here getting 14,500 views. Responsive!

c) "I understand your impatience, but things are not magical and demand severe development. The few bugs you encounter cannot prevent you from serious audio works with the MMV; and just as the venerable analogue Moog System 55, you can workaround most of them."

Yes, this thing definitely does demand severe development, and no one expects magic - just working software, preferably in a shorter timeframe than 4...5...6...7....? years. And I can't work around a total crashout that causes me to restart my host. I didn't buy the thing to only be able to use it as a standalone.

Glad that the company seems to have finally hired someone to do damage control, and I hope that your claims of current work on MMV are legit. I can't speak for everyone here, but I really do want the software to work, because I feel like it's potentially great, just not in the current iteration. It would be swell if you'd come in here and update everyone on the status when you talk to the developers.

Sweep

  • Full Member
  • ***
  • Posts: 243
  • Karma: 7
Re: Bugs, Bugs, and more Bugs...Massive MMV2 Bug List
« Reply #46 on: July 13, 2009, 05:14:04 pm »
Thanks, Antoine, for clarifying that I'm not an Arturia employee.  I think it's a measure of the damage Elhardt's complaints have done that people assume someone who speaks well of the MMV must be a company employee.

To recap, once again, Kenneth Elhardt has pontificated at great length about the shortcomings of the MMV as a substitute for the original hardware Moog modular, but it's been established at the Moog forums and elsewhere that he has no experience of the Moog modular whatsoever.

He's put great effort, as always, into listing what he regards as major issues, while being oblivious to the massive problems people had with the original Moog modular.

Yes, there are bugs, but most of them make little practical difference to playing this instrument. The ones that do, in common with some of the other Arturia products, tend to be interface problems with third party software. While I sympathise with Porfiry's problems, and would try to help if I was using the MMV in the same environment he's using it in, it's clear from his second post that the dropouts and so forth that he reports happen when the MMV is run in conjunction with other software. Regarding the statement that he didn't buy the MMV to only use as a standalone, I take the point being made - but I'd also point out that the original Moog modular was precisely a standalone in most instances.

What I'm getting at is that most of the bugs reported of the MMV are relatively minor and speaking as a musician I'd say they're not outlandish considering the complexity of the instrument and the shortcomings of the original. The more serious bugs tend to be interface issues with other software not written by Arturia. Some of that software may be quite widely used, so the problems do need to be sorted, but none of this amounts to the MMV being unuseable or severely limited.

I honestly wish there were a lot more Moog modulars around. Then people might realise you can't just walk up to one of these things and sound like Wendy Carlos or Keith Emerson. You can't usually run it with sequencing software, either.

The MMV is an instrument with a lot of potential and a few niggles. This topic would imply that it barely works at all and falls over at the slightest opportunity. That simply isn't true. As I've said before, the real test of whether it works is music made with it, and it definitely does make music. I've got music on my website to prove it. In all the time I've been using it, it's only crashed once - when someone who'd worked with Harald Bode told me how he'd configured a new design of hardware, and I tried to emulate that on the only instrument I had that was capable of the same kind of setup, the MMV, which crashed due to problems inherent in all software. Any software would have crashed at that point, but the MMV was the only software even capable of the experiment.

If the early synth pioneers who struggled with the Moog modular had expected easy results, we would never have had Switched on Bach, or Tarkus, or whatever.

The reason I keep stessing this is because I think it would be a tragic loss to music if instruments like the MMV got such an undeserved reputation that musicians didn't try to get to grips with them. The MMV is much easier to get to grips with than an early hardware synth, and rewards the musician much more readily. But it seems those of us who are making music with the MMV and similar instruments have to prove a point, just as the first wave of synth pioneers did.

Maybe if everyone started with a VCS3 and a totally baffling second-hand mixing desk, as I did many years ago, the beauties of the MMV would be more apparent.

Koshdukai

  • Beta-testers
  • Sr. Member
  • *
  • Posts: 444
  • Karma: 20
Re: Bugs, Bugs, and more Bugs...Massive MMV2 Bug List
« Reply #47 on: February 09, 2011, 06:16:01 pm »
Oscillators
-----------

(1) An osc has a total of 4 exponential modulation inputs, two on the osc and two on the osc controller.  Connecting an audio rate osc or noise source into any one of those causes 3 of them to stop working.  This is one of the most major module bugs in MMV.

(2) The sinewave can't hard/soft sync.

(3) Can't hard/soft sync more than one osc to the same source osc.  Trying to do so keeps one osc sort of sync'd and the other not sync'd, with both making strange clicking sounds depending on their frequency settings.

(4) The second PWM nut improperly displays the setting of the first PWM nut when turned, so it can never be set numerically accurate.

(5) Saving a patch with an osc bank set to LFO mode may not get you the same sound when loaded back into the synth.  In my case a polyphonic patch plays only intermittent monophonic notes.  I have a set of patches that only work correctly after I manually cycle through the K1,K2,K3,K4,No setting back to the LFO setting after I load them.

(Poor Design Issues).  The pulse width knob also changes the triangle and sawtooth waves into other waveforms.  Unfortunately Arturia put the sawtooth wave at the leftmost position, and the triangle and square waves at the rightmost position.  So you can't get sawtooth (at the proper pitch) and triangle and square waves at the same time from an osc bank.  Mixing waveforms together on an osc is common, and when standard waveforms like sawtooth and triangle change into other waveforms as the pulsewidth is changed, it's annoying and requires bringing in another osc bank and syncing it to the first, using more oscs to acheive what should be done with just one.  Those other waveforms aren't even very useful.  Turning the pulsewidth knob gives you a hardsync'd sawtooth waveform, something that can already be done by simply syncing one osc to another.


Had to check this list to see if the bug I'm experiencing was already known before MMV2.5

btw, thank you very much for this, Elhardt, despite some of the posts here, I would say that I consider almost all of the points you mention as valid and good suggestions when not considered by some as plain bugs. The advantage of having a *reliable* virtual representation of the unreliable hardware version is exactly to increase it's usefulness and ease of use and understanding when it doesn't clashes with the original. Looking at all the other Arturia's virtual instruments, I guess this embrace and extend philosophy is one of the driving factors when spec designing the emulations, and by many, expected also with MMV, IMHO.


...anyway, enough blabbing about concepts, let's talk about bugs:


I'm having trouble getting any sane signal out of Square and Triangle outs of OSC1 on some patches that initially were saved using Saw or Sine, for instance.

So, loading Template_wav - Saw, and connecting Square to the Filter instead of Saw, I get no sound. Doing the same with Sine works fine, but Triangle also makes no sound or sometimes a quick crackling on note trigger.

Taking the filter out of the audio path, just to be sure, connecting OSC1 directly to VCA1 makes no difference on getting Square and Triangle to work, but Saw and Sine still works fine.

If I change to a Square based preset, then I have to problems going through those steps described above, getting audio out of all the OSC1 waveshape outs. So Sine, Triangle, Square and Saw, all work fine this time.


Am I doing something wrong or forgetting some obvious step, wire or knob setting when starting with tha Saw template or is this a bug ?

I'll try doing a screen capture video about this, if this can't be reproduced or explaind by others.
« Last Edit: February 09, 2011, 06:20:51 pm by Koshdukai »

Koshdukai

  • Beta-testers
  • Sr. Member
  • *
  • Posts: 444
  • Karma: 20
Re: Bugs, Bugs, and more Bugs...Massive MMV2 Bug List
« Reply #48 on: February 09, 2011, 10:23:25 pm »
ok, found *my* problem :P ...driver's width was at 0.00 on that particular preset... the one I was using as the starting point ::)

oops, should've watched more closed at that knob value/position ;D

arturiadontbug

  • Apprentice
  • *
  • Posts: 8
  • Karma: 0
Re: Bugs, Bugs, and more Bugs...Massive MMV2 Bug List
« Reply #49 on: January 05, 2014, 03:40:56 pm »
The manual says you can click on a cable to select it and press the delete key to delete it.  Wrong, the manual also lies. 

This is still in the latest manual, and as far as I can tell, still doesn't work. It'd be nice if it did. If it's not meant to work after all, what is the use of being able to select the cables by clicking on them?
Also, deleting the cables via the right-click menu could be improved too. Currently the "remove connection" option removes all connections to that socket. There's no way to remove a specific single connection. A better system, I think, would be if the "remove connection" option was removed, and the (currently inactive) options listing the cable destinations "Connected to ..." could be changed to "Delete connection to ...". Then individual cables could be removed easily. Edit: This is what the manual says should work too...
Another thing that would be useful in that menu would be something identifying the actual socket clicked on. Knobs can be hovered over to show a tooltip with the name of the knob, but there's nothing to easily identify the sockets.
But as this thread is ancient, and so is the MMV, really, is there any hope of things like this ever being fixed?

Edit: Apparently the delete-key-to-remove-cable /does/ work sometimes. My host was catching the keypress. It doesn't work in the stand-alone version either though, so that must be catching it too.
« Last Edit: January 31, 2014, 03:37:10 pm by arturiadontbug »

shaman

  • Newbie
  • *
  • Posts: 1
  • Karma: 0
Re: Bugs, Bugs, and more Bugs...Massive MMV2 Bug List
« Reply #50 on: January 19, 2014, 06:55:57 am »
Wow, fantastic someone took the time to list all these issues. Thank you!

Came up here to see if my issue was known - amazingly first reported in 2006 here and still not fixed?

>>(1) Polyphonic patches plagued with clicking/popping noises on their attacks.

Hard to understand why more people aren't seriously complaining about this as it's so obvious and stops me from using Modular V in poly mode - a real shame as the little I've tried in poly it sounds great otherwise. Maybe a faster CPU would help? I've an 8 year old L7 Core Duo chip. Maybe others aren't complaining b/c they've faster chips that obviates this bug / design issue?

arturiadontbug

  • Apprentice
  • *
  • Posts: 8
  • Karma: 0
Re: Bugs, Bugs, and more Bugs...Massive MMV2 Bug List
« Reply #51 on: January 31, 2014, 04:57:08 pm »
I get pops even in mono mode... Try just connecting a triangle or sine oscillator output straight into the output VCA, and set attack to 0. The strange thing is that sometimes it happens on every note press, sometimes it only happens on a "new" note, and further presses on the same note don't click, and sometimes it doesn't happen at all...
I don't have the fastest machine either, but even set to poly with all the effects enabled, it doesn't use that much CPU, so I don't think it can be that simple.

A couple more things not in the initial list:
Sync connectors on oscillators look like normal signal connectors rather than trigger-type connectors, when they are unconnected anyway. When connected they look correct.
Signal outputs can be dragged into trigger-type inputs, creating useless "fake" connections. Clicking on the input shows it's connected to "[2]" or some other number depending on what you dragged to it.

 

Carbonate design by Bloc
SMF 2.0.8 | SMF © 2014, Simple Machines