November 28, 2015, 01:51:28 am
Welcome, Guest. Please login or register.
Did you miss your activation email
News: Feel free to email any encountered problem at

Arturia Forums

Author Topic: KEYLAB 88 issues - preset browsing, fader inactive  (Read 309 times)


  • Newbie
  • *
  • Posts: 2
  • Karma: 0
KEYLAB 88 issues - preset browsing, fader inactive
« on: July 09, 2015, 10:16:31 am »
Hello Arturia,
just bought a keylab 88 and since a week I struggle to make this thing work with Analog Lab.
I have 2 issues : my preset browsing knob is simply not working (the category encoder is ok) and secondly, one of my fader (7) is not working but moves my Fader nr 5.
I managed to make analog Lab work with all the faders in the first days (the preset does not work since the beginning - I assume it's a software issue midiCC: 114 but moves from 63 to 65).
I updated the firmware, Analog Lab and the midi control center (unified) but nothing changed. I slightly regretting my purchase, what's the point to have something which has been heavily promoted as the ultimate controller, seen many videos on the web which help me deciding on which controller I choose, but at this price range, I would muchly appreciate the support to find a quick solution. Moreover, it's supposed to work directly and semalessly with Analog Lab, but sometimes, I wonder if we have to change the settings in midi control center each and every time to get something working... In vst mode, (not to mention Ableton 9.2 crashes) I got the same issue... So basically, I cannot benefit from this keyboard, and I would say unusable... The purpose of a midi keyboard loaded with a dedicated software is to work directly, no?
Anyone experiencing this?


  • Apprentice
  • *
  • Posts: 32
  • Karma: 1
Re: KEYLAB 88 issues - preset browsing, fader inactive
« Reply #1 on: July 09, 2015, 11:08:38 am »

Sorry for those issues.

-->> Have you made a midi monitoring of the browsing encoder ?

You can do it on the Midi Control Center, Click View -> Midi Console

Also in the midi console, what is assigned to this knob if you select it ?

-->> About the fader, have you clicked on it still in the midi control center ?

Have tried to reassign it by clicking on it and selecting the right CC ?

It still moves the fader N 5 ?

I Invite you to create a ticket, where we will be able to handle the situation, and go for a replacement / repair of the unit if necessary.

You can write my name in the subject, so Ii will be easier for me to see it.

Looking forward to hearing from you.

Best Regards


Edouard Arturia - HelpDesk


  • Newbie
  • *
  • Posts: 2
  • Karma: 0
Re: KEYLAB 88 issues - preset browsing, fader inactive
« Reply #2 on: July 09, 2015, 01:45:58 pm »
Hello Edouard and thank you for the quick reply.
I'm at work now, I will tell you what I get ion the midi control center when I come back home.
What I found strange is that we are not supposed to change something as (as far as I know) normally the working memory is supposed to be configured by default to work with analog lab...
Concerning the repair, are you sure it is a hardware problem? The knob itself is not loosy or something, I assume it's simply a software bug or something like this...
I will keep you posted, thanks in advance


Carbonate design by Bloc
SMF 2.0.11 | SMF © 2015, Simple Machines