October 25, 2014, 02:11:10 pm
Welcome, Guest. Please login or register.
Did you miss your activation email
News: Arturia's webmaster is glad to offer you these brand new forums ! Have fun using it and feel free to email any encountered problem at webmaster@arturia.com.

Arturia Forums



Author Topic: Minilab no longer works with Logic 9 after firmware update  (Read 793 times)

alieneye

  • Apprentice
  • *
  • Posts: 3
  • Karma: 0
Minilab no longer works with Logic 9 after firmware update
« on: August 02, 2013, 09:19:52 pm »
hello all,

i am running the following system:

macbook pro (late 2009)
Mac OS 10.6.8
2.4 GHz Intel Core 2 Duo
4GB of Ram
Logic Pro 9.1.8

minilab firmware version 2.1.0.1

my issues are as follows, please excuse the length, i wish to be thorough in my detail.  also, i have search this forum for solutions to these issues with little sucess

when i first plugged the minilab into my CPU, i opened up logic to play around with it to get a feel of its abilities.  it worked great. like a champ.  i could cycle thru midi channels, logic responded to modulation wheels, knobs, keys, and pads.

i then closed logic and opened the minilab control center to edit the note parameters of the pads.  i kept getting the same error may otherss were getting, the "no keyboard detected" message.  so i found on this forum that i had to turn off my computer, plug in the minilab, turn on computer then open MCC once machine finished booting.  this seemed to work.  i was able to change the parameters i wanted to and save them to the board.  i also went ahead and upgraded the firmware of the minilab from 2.0.0.0 to 2.1.0.1

since the firmware upgrade to the minilab, i no longer need to shut my computer down to get MCC to see the keyboard.  that issue seems to be fixed.  i just make sure the minilab is plugged in before i open up MCC and it works every time.

now i am experiencing a new problem.  since i updated the firmware, the minilab no longer works with logic pro 9.

i am very proficient in Logic and have done everything i am aware of within the midi and environment setting within logic to get it to work, but i've had no success.  i have thoroughly read thru the manual and it does not indicate that there is a step i am missing to get the new firmware to work with third party software.

i have also checked this entire site for a manual addendum for the new firmware and have found no such file.

what am i missing, or is this a new issue that needs to be addressed?

on a side note, the minilab works 100% with the analog lab software, however i specifically picked this up as a travel keyboard to use with Logic exclusively.

thanks for any info that i can get to solve this problem.  also i apologize in advance if i overlooked the solution to this problem within this forum, if it is here.
travis
« Last Edit: August 03, 2013, 09:10:59 am by Adrien »

Adrien

  • Global Moderator
  • Sr. Member
  • *****
  • Posts: 281
  • Karma: 3
Re: Minilab no longer works with Logic 9 after firmware update
« Reply #1 on: August 02, 2013, 11:07:54 pm »
Hi

just to try,
could you tell what does not work : is it that it does not behave correctly, or it is not recognized, do you have notes?
just an idea, on the resource page there is a video to change midi mode, perhaps try the config on pad 2 for absolute mode instead of relative
good luck
best
Adrien Courdavault
DSP & Software engineer
Arturia

alieneye

  • Apprentice
  • *
  • Posts: 3
  • Karma: 0
Re: Minilab no longer works with Logic 9 after firmware update
« Reply #2 on: August 02, 2013, 11:34:41 pm »
when i say i doesn't work with logic i mean that logic is receiving no midi information at all.  the transport in logic shows no "midi in" information.  before the firmware upgrade to 2.1.0.1 logic received any and all midi info that the minilab sent. notes, control changes, prog changes, pad info, mod/pitch wheel, midi channel change, etc were all being received by logic prior to firmware upgrade.

not sure what resource page you are referring to but midi mode is a pretty easy thing to change on this.  i tried the presets on every pad, still no luck.

if the answer is to downgrade the firmware back to 2.0.0.0 until this issue is worked out on Arturia's end, i'd be happy to do so, just need a link to the old firmware.

thanks for the info
travis

alieneye

  • Apprentice
  • *
  • Posts: 3
  • Karma: 0
Re: Minilab no longer works with Logic 9 after firmware update SOLVED! derp
« Reply #3 on: August 02, 2013, 11:54:00 pm »
my bad,

i got it working.  it was disconnected in logic's environment.  Derp.

working like a champ.

thanks for bearing with my silly oversight.  this thing is great!

travis

 

Carbonate design by Bloc
SMF 2.0.8 | SMF © 2014, Simple Machines