November 22, 2014, 04:08:44 am
Welcome, Guest. Please login or register.
Did you miss your activation email
News: Arturia's webmaster is glad to offer you these brand new forums ! Have fun using it and feel free to email any encountered problem at webmaster@arturia.com.

Arturia Forums



Author Topic: MB Connection does not launch or connect  (Read 1898 times)

Corporael

  • Newbie
  • *
  • Posts: 2
  • Karma: 1
MB Connection does not launch or connect
« on: January 11, 2013, 04:17:25 pm »
When I extract the MB connection for OSX, it puts the folder on the desktop, and I am able to view the two files.  When I launch the application it simply does nothing, whether the MB is connected via USB and turned on, turned on holding both octave switches etc.  or any other way...  I receive no notifications of any kind at any point, just null.  I am running OS Lion, 10.7.5.  Thanks!

kevinmoore73

  • Apprentice
  • *
  • Posts: 13
  • Karma: -1
Re: MB Connection does not launch or connect
« Reply #1 on: January 11, 2013, 05:40:23 pm »
There is a problem with the way Arturia is packaging the software for OS X.  They're doing it in such a way that OS X doesn't know that the application is an executable.  To fix it, go into Terminal, navigate your way to the application folder, find the "MiniBrute Connection" file and chmod it 755.

This is what I did on my system with the old version of the software.  You will need to adjust for whatever directory you're using on your system and also adjust for the new version.

cd /Applications/MiniBrute/MiniBruteConnection_V1.0.1.app/Contents/MacOS
chmod 755 "MiniBrute Connection"






Bruno@arturia

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 686
  • Karma: 27
Re: MB Connection does not launch or connect
« Reply #2 on: January 14, 2013, 10:55:14 am »
Hi,
can you launch it from a terminal, to get the error message from OSX.

open the terminal,
go to You_folder_name/MiniBrute Connection V1.0.2.1/OSX/MiniBrute Connection_V1.0.2.1.app/Contents/MacOS/
launch MiniBrute Connection
copy and send me the output messages.

If you don't have a clue what I'm talking about, let me know I'll send you more detailed instructions.

Thanks
Bruno
Bruno
Arturia Hardware

kevinmoore73

  • Apprentice
  • *
  • Posts: 13
  • Karma: -1
Re: MB Connection does not launch or connect
« Reply #3 on: January 14, 2013, 05:53:36 pm »
He'll get a permission denied message unless he sets the application to be executable:

macpro:MacOS kevin$ ./"MiniBrute Connection"
-bash: ./MiniBrute Connection: Permission denied

Bruno@arturia

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 686
  • Karma: 27
Re: MB Connection does not launch or connect
« Reply #4 on: January 15, 2013, 10:40:27 am »
Hi Kevin,
sorry I haven't seen your previous message before posting my first message. Indeed it's likely to be a permission issue.
Thanks for the workaround.

Did you had this problem with the latest version 1.0.2.1 too?
I have to say I'm not really used to package software for OSX, I'll double check this for the next release.
 

Thanks
Bruno
Arturia Hardware

kevinmoore73

  • Apprentice
  • *
  • Posts: 13
  • Karma: -1
Re: MB Connection does not launch or connect
« Reply #5 on: January 15, 2013, 12:34:53 pm »
Yes, I had the problem with 1.0.2.1.

Bruno@arturia

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 686
  • Karma: 27
Re: MB Connection does not launch or connect
« Reply #6 on: January 16, 2013, 04:33:14 pm »
ok
Bruno
Arturia Hardware

kevinmoore73

  • Apprentice
  • *
  • Posts: 13
  • Karma: -1
Re: MB Connection does not launch or connect
« Reply #7 on: January 16, 2013, 04:43:45 pm »
I believe this is happening because someone is copying the .app from OS X to Windows and then zipping it on the Windows machine.  The .app should be zipped on the OS X machine so that it preserves the resource fork and therefore the permissions.

tertior

  • Full Member
  • ***
  • Posts: 154
  • Karma: 2
Re: MB Connection does not launch or connect
« Reply #8 on: January 16, 2013, 07:07:58 pm »
hmm it's ok for 10.6.6
for 10.5.8 and before  and all PPC bah bad architecture.
Can you open MB connection with Windows on your Mac 10.7 ? (take the good application for it )

mantrak

  • Apprentice
  • *
  • Posts: 13
  • Karma: 0
Re: MB Connection does not launch or connect
« Reply #9 on: September 22, 2013, 12:25:05 am »
I have the same problem. I have OSX 10.6.8 and latest MB Connection software. Tried to move folders around, tried to change rights from ReadOnly to ReadWrite, nothing. Won't start.

USB is connected, MB detected by the system.

Anybody?
___________
MiniBrute, BeatStep, V Collection, DSI Mopho KB, DSI Prophet 12, Moog LP Stage II, Minimoog, Logic...

tertior

  • Full Member
  • ***
  • Posts: 154
  • Karma: 2
Re: MB Connection does not launch or connect
« Reply #10 on: September 22, 2013, 12:45:14 pm »
Ok you have the latest firmware ? Now, execute the post of Bruno who he says how it  do for open MB in the terminal


you got a msg style : Last login: Sun Sep 22 12:40:41 on ttys000
tertior:~ tertior$ /Users/tertior/Downloads/MiniBrute_Connection_1_0_2_1/MiniBrute\ Connection\ V1.0.2.1/OSX/MiniBrute\ Connection_V1.0.2.1.app/Contents/MacOS/MiniBrute\ Connection ; exit;
-bash: /Users/tertior/Downloads/MiniBrute_Connection_1_0_2_1/MiniBrute Connection V1.0.2.1/OSX/MiniBrute Connection_V1.0.2.1.app/Contents/MacOS/MiniBrute Connection: Bad CPU type in executable
logout


[Opération terminée]
You see here that the problem is a bad CPU.

mantrak

  • Apprentice
  • *
  • Posts: 13
  • Karma: 0
Re: MB Connection does not launch or connect
« Reply #11 on: September 22, 2013, 01:58:15 pm »
Tertior,

I can not know what firmware I have, since I cannot run MiniBrute Connection app.

I cannot use Terminal or Console. I can run only applications. If I need to change some file permissions (?) I need some human friendly utility for that, not command line recipes I'm affraid.

I peeked into Console Messages and found "Permission denied" error logged. Took me too long.

My Comp is iMac with 2.4 GHz Intel Core 2 Duo processor and OSX 10.6.8. I can work normally with MiniBrute from Logic via USB midi.

But I am stuck because I cannot change MiniBrute midi channel. MiniBrute Connection app won't run. Arturia helpdesk is offline from yesterday, they obviously have problems migrating the system to FoxBugz.

Help!
___________
MiniBrute, BeatStep, V Collection, DSI Mopho KB, DSI Prophet 12, Moog LP Stage II, Minimoog, Logic...

tertior

  • Full Member
  • ***
  • Posts: 154
  • Karma: 2
Re: MB Connection does not launch or connect
« Reply #12 on: September 23, 2013, 11:22:49 am »
Erf, delete all appz,preference etcof  Minibrute and reload the application on Arturia site and open it of your destop ; why you can't use terminal?
Try too utility disk and autorisation verification  ::)





mantrak

  • Apprentice
  • *
  • Posts: 13
  • Karma: 0
Re: MB Connection does not launch or connect
« Reply #13 on: October 09, 2013, 10:03:55 pm »
I solved the problem by deleting the app and installing it again. As a precaution this time I did not used Zipeg for unzipping, now I used "Archive Utillity". I got the idea from someone mentioning Minibrute Connection.app file attributes not being properly zipped or unzipped in some circumstances...

So I still don't know if Zipeg was the problem and I leave that to Mac OSX experts.

Thanx anyway!
___________
MiniBrute, BeatStep, V Collection, DSI Mopho KB, DSI Prophet 12, Moog LP Stage II, Minimoog, Logic...

 

Carbonate design by Bloc
SMF 2.0.8 | SMF © 2014, Simple Machines