November 22, 2014, 11:38:46 am
Welcome, Guest. Please login or register.
Did you miss your activation email
News: Arturia's webmaster is glad to offer you these brand new forums ! Have fun using it and feel free to email any encountered problem at webmaster@arturia.com.

Arturia Forums



Author Topic: Firmware upgrade freezes, stays at 0% (Solved)  (Read 987 times)

MarkStarhill

  • Apprentice
  • *
  • Posts: 4
  • Karma: 0
Firmware upgrade freezes, stays at 0% (Solved)
« on: January 06, 2013, 01:29:40 am »
Hi,

I got my minibrute a week ago. The same day i upgraded the firmware and i could connect via the editor.

Today I could nor connect through the editor so I tried to reinstall the firmware upgrade.

It got stuck at 0% for ten minutes so I tried rebooting the Minibrute. It boots into download mode (the five octave leds are on) and nothing else happens. I tried several times to complete the firmware upgrade process but allways got stuck at 0%.

Please help

UPDATE:

After restarting my computer and unplugging all other USB gear i finally got the upgrade to flash.

The I replugged my other gear and the connection to the Minibrute was lost. Something seems to be wrong here.

The other gear i have plugged in is:

Novation XIOSynth
Korg NanoKontrol.

I also discovered another issue.

In my DAW (Reaper) the Minibrute fails to connect as a MIDI device. I can see the input and output devices but when i try to activate them Reaper tells me the inputs and outputs labelled Minibrute cannot be opened.

UPDATE 2:

After scanning the forum i found that I had to close MinibruteController for MIDI to work.

The editor software seems a bit shaky and fails to connect quite often but my aqute issue is solved.

« Last Edit: January 06, 2013, 02:17:53 am by MarkStarhill »

Bruno@arturia

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 686
  • Karma: 27
Re: Firmware upgrade freezes, stays at 0% (Solved)
« Reply #1 on: January 07, 2013, 12:05:59 pm »
Under windows only one software can connect to a midi device. So indeed if Minibrute Connection is connected, then Reaper can open the Midi device. But the opposite is true too: If reaper is connected, Minibrute Connection will fail to connect. It one of the strong limitation of Windows Midi driver.

I'm very surprised connecting an other USB device could disconnect the Brute. unfortunately I don't have  Novation XIOSynth or Korg NanoKontrol, but I'll check with other Korg and novation devices. But are you sure the disconnection is not related to a software you may have launch while plugging theses devices, such as reaper? I could be this windows driver thing too.

If you have some spare time to investigate I would be very grateful :)

Thanks!
Bruno
Bruno
Arturia Hardware

MarkStarhill

  • Apprentice
  • *
  • Posts: 4
  • Karma: 0
Re: Firmware upgrade freezes, stays at 0% (Solved)
« Reply #2 on: January 08, 2013, 01:56:28 pm »
I wasn't really methodical while trying to solve the issue. It might be the case that I had some other MIDI software running while trying to connect to the Minibrute.

I'll try to do a more methodical test and post my findings here.

I have another question though; When the minibrute is in download mode (all five octave lights on), is there a way of getting it back to normal operation without the minibruteconnect software?

Regards
Mark

Bruno@arturia

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 686
  • Karma: 27
Re: Firmware upgrade freezes, stays at 0% (Solved)
« Reply #3 on: January 09, 2013, 09:44:51 am »
Quote
I have another question though; When the minibrute is in download mode (all five octave lights on), is there a way of getting it back to normal operation without the minibruteconnect software?
reboot :)
Bruno
Arturia Hardware

MarkStarhill

  • Apprentice
  • *
  • Posts: 4
  • Karma: 0
Re: Firmware upgrade freezes, stays at 0% (Solved)
« Reply #4 on: January 10, 2013, 05:09:20 pm »
Are you sure?

I'm certain that when i rebooted the MB (by turning it of via the switch and waiting about 15s, then turning it back on) the five octave leds were still lit, the arpeggiator led wasn't blinking and the machine was silent. Maybe i should have pulled the power cord too?

I was afraid that I wouldn't get it running again since the firmware wouldn't flash (stuck on 0%). After I got the firmware to flash, the MB returned to normal operation after reboot.

Bruno@arturia

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 686
  • Karma: 27
Re: Firmware upgrade freezes, stays at 0% (Solved)
« Reply #5 on: January 11, 2013, 10:34:18 am »
Ho ok if your MB is stuck to 5 octave leds mode because of a faulty update, it's different.
In this situation the firmware may be corrupted. the machine with not work until you achieve to send it the full firmware.
Bruno
Arturia Hardware

MarkStarhill

  • Apprentice
  • *
  • Posts: 4
  • Karma: 0
Re: Firmware upgrade freezes, stays at 0% (Solved)
« Reply #6 on: February 05, 2013, 10:28:43 am »
Hi Bruno.

I haven't been able to replicate my previous problems, so you can probably consider this issue null and void.

Probably just me panicking because my minibrute was unplayable for a while. :-)

Thanks for your quick responses.

/Mark

 

Carbonate design by Bloc
SMF 2.0.8 | SMF © 2014, Simple Machines